0

I have SharePoint site which was working fine. My site has custom page with custom visual web parts. Suddenly i am getting Web Parts Maintenance Page error when accessing my page. I tried to find any clues in SharePoint log files but i can't find out the reason for this error. Can anyone tell me the possible scenarios for this kind of error?

1 Answer 1

0

Actually the reason can be thousand. Are you using custom web parts? What that does?

Usually into ULS log you have all the reason about errors.

I suggest to you to use something like this: https://sharepointlogviewer.codeplex.com/

or this:

http://archive.msdn.microsoft.com/ULSViewer

to understand what's going on.

10
  • I am using custom web parts only. It just loads grid with data from database. I have checked using ULSViewer, but could not find exact reason. Do i need to consider all category and levels in log file?
    – Suren
    Aug 21, 2013 at 7:56
  • Yes, btw are you use a dev env? if yes, you can debug your application Aug 21, 2013 at 7:57
  • We are not getting this issue in our dev env. This issue occurs in production side and we have only sharepoint log files to find the issue.
    – Suren
    Aug 21, 2013 at 8:03
  • do you have a stage env? Aug 21, 2013 at 8:13
  • yes we have staging env..
    – Suren
    Aug 21, 2013 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.