2

I'm having a strange problem, on the server running Central Admin(Server 1), I cannot install any .exe files, they all go straigh to "An error occurred while running detection" after I accept the license agreements.

SharePoint is in RTM version 14.0.4763.1000. Only on the server NOT running Central Admin(Server 2), a patch is installed (Microsoft Update for Microsoft SharePoint Server 2010 (KB2560890) 14.0.6106.5009) http://support.microsoft.com/kb/2560890 The PatchStatus page shows this update as Missing/Requred on Server 1.

I can install .exe files on Server 2. (I tried with SP1 but canceled).

I've tried to run different .exe files, run as administrator, logged in as different users. (The account to the guy who had this server before me and got DB access, farm admin, SPFarmAdmin, and my personal farm admin account) None seems to work.

PSConfig will not run, because of the missing KB on Server 1.

I'm kind of stuck, and none of the top google hits provided any usefull tips. Hope anyone here got some usefull tips! Thank you!

1

I ran into similar issue deploying update(s) to MS Lync 2013. I repaired the installation of Lync (by running setup.exe without any configuration xml files - Just rename the config.xml to config_old.xml or something). Choose to 'Repair' the installation and restart the computer at the prompt. The patches can be installed without further issues. Interestingly, I couldn't run a silent repair from the command line. I tried 'setup.exe /repair {product code of Lync}' without the quotes and it threw an error saying that my installation is corrupt. The GUI repair worked. HTH

0

This was fixed by running a repair on SharePoint Server 2010 on Server 1. After this, patches was possible to install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.