I created a copy of the approval workflow to run on a infopath form library once an item has been created. When the workflow is triggered, after less than a minute the workflow fails with this error: "The Workflow could not set content approval status. Enable content moderation for this list and run the workflow again"

Oddly enough, the default approval workflow works fine.

There are only two differences between my workflow (the one that is needed) and the default

1.There is a step in the new workflow that assigns the approver using a field from the form library 2.The workflow is associated with the content type "form" whereas the default approval workflow's association is "all". I cannot change this option, I'm assuming because i have the workflow associated with the "list(form library)" of the infopath form

* also, if possible, can an expert come along and edit my tags? I want to add the tag "Moderation" to this question because it is used in the error message on SharePoint*

closed as too localized by Alex Angas Jun 14 '11 at 23:55

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    I don't know why this was closed as "too localized", except that the specific differences stated were largely irrelevant. But this is a very general error that can happen, regardless of what you are changing, at least from what I found for my cause. The cause for me was because "Require content approval for submitted items" was unchecked in the Advanced Settings of the document library, in SharePoint Designer, and needed to be checked. – vapcguy Jun 24 '15 at 22:12