3

When I navigate to sites on my local Windows 7 workstation with SharePoint 2010 installed I see 'System Account'. I would like to see my domain account as the user.

When I try to login to SharePoint as a different user with my account, I get an Unauthorized 501 error.

I have read a little that SharePoint is recognizing me as the one that installed SharePoint and so it thinks I am the System Account. We have the exact scenario on a virtual machine as well.

How do we rectify this situation?

  • If you are only seeing this for a single user (and it is the user who did the installation) is it worth spending time resolving? Is this a purely cosmetic issue? – dunxd Jul 18 '11 at 16:04
4

SharePoint will display the "System Account" for the farm administrator.
In addition every user that has "Full control" over the web application through a user policy and where the "Account operates as System" checkbox is enabled will be displayed that way.


If you want to change the farm account you need to register this new account under "Application Management" in "Security" section and then "Configure Manage Accounts". Details can be found in this article: http://www.tsls.co.uk/index.php/2011/01/21/how-to-change-the-farm-service-account-in-sharepoint-2010/

  • I like this expanation of the Farm Account and the other special accounts for 2007. Most still applies for 2010. woodywindy.com/archive/2009/06/12/… – Tom Resing Nov 15 '11 at 1:41
  • Tom, only the original poster of the question is able to mark as answered. The rest of us can upvote. – SPDoctor Nov 15 '11 at 10:36
1

Like you said, you're recognized as the farm account, because you've installed your Server with that account. Now you can either create a new account for your person or change the farm account, which is a bit more complicated.

0

I've had some weird issues with user accounts and permissions when accessing sharepoint sites from a browser running on the server Sharepoint is installed on. Try accessing from a different machine and see what happens.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.