0

I have a list with a workflow that runs for every item that is added or changed. I imported about 700 records in to the list via Microsoft Access. Immediately after the import only 100 or so items had a workflow status of Completed. The rest all say Starting.

It has now been almost 2 hours and there are still 400 items that say Starting.

How can I speed up this process?

0

There is a SP Workflow Postpone Threshold, and by default it's set at 15. You can raise this by using the Set-SPFarmConfig namespace in Powershell using the WorkflowPostponeThreshold parameter.

//The following powershell command raises the Workflow Postpone Threshold to 30

Set-SPFarmConfig -WorkflowPostponeThreshold 30

SP 2010 Workflow Limitations

Set-SPFarmConfig

  • That did it! I set it to 100 for a bit and everything cleared up. Thanks! – longneck Aug 9 '13 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.