2

We do not have on-premise SharePoint 2013 in production but the three dev farms that I have access to all have the same odd behavior. The majority of SMTP functions work correctly (adding to groups, alerts, etc.) but the "share with" option inside of document libraries do not send an e-mail invitation. Permissions are changed correctly so you can manually send a link but this is not how we want this system to work.

There are no event log errors that I can find related to this and since other SMTP functions work, I doubt that there are firewall or mail host configuration error. They are single front-end test farms. Any suggestions on where to look?

3

I have figured out what the problem was. The "share with" function uses the e-mail address of the currently logged on user and NOT the farm-wide SMTP setting. The error was due to fact that we had SMTP relay restrictions based on from address that did not allow this new behavior.

  • 1
    can you please elaborate on what the solution you did to resolve the problem like to change SMTP settings or something. Thanks Swanle – user28374 Jun 4 '14 at 19:05
  • 1
    This was pretty specific to our Exchange configuration so this may not apply to anyone else's network. We have an internal SMTP server that is wide open for internal-only e-mail. To use this SMTP server, the from address has to be from a specific sub-domain (i.e. from SomeApp@internal.domain.com) however, the share-with feature uses the real email address of the current users (i.e. First.Last@domain.com). So we had to point to a different SMTP server that allows relay of @domain.com – SBWorks Jun 6 '14 at 4:20
0

We had this issue and it was because we are using a full control customize permission level and the option for manage permission is unchecked, we tested by raising the permission to full control and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.