6

I want to make it so that my title link DOES NOT drill down to the underlining list ... is this possible?

alt text

1
7

If you want the title in a view to be without the link, modify your view and unselect "Title (linked to item with edit menu)" and select "Title" and move it up to its correct location.

This will render the title as text only.

EDIT: Sorry, didn't see your yellow marking. You need to edit the webpart as Steve said, but instead of clearing it put a blank space in the "Title URL" property.

EDIT: Didn't test that out before posting.... If you put a pound "#" in the Title URL you get a link to current page. Not solving the problem completly, but better than nothing.

1
  • This worked with the # sign, wish I could just make it NOT a link, but doesn't look like I can. This works though, thank you! – mattruma Dec 1 '10 at 16:03
2

On the right side of the screen, the Web Part Properties tool pane will appear. Expand the section called Advanced.

Remove Titile URL content and just put #

Click on Apply .

This worked for me.

2

My Solution:

Write "/none" or something like that in the Title Link Field...

Now, with a short jQuery code you can remove all your Title Links which are set to "/none".

jQuery code:

$(document).ready(function(){
$("a[href='/none']").removeAttr("href");
});

I wrote this also in my Blog

I used my solution because if you use the "#" character, there is a link linked to current page - not very nice at all.

Hope this helps

1

If you convert it to a DVWP, the title does not render as a hyperlink. If that isn't an option, replace the Title URL in the web part properties to # or about:blank for the current page or some other URL if you don't want users to access the underlying list directly.

1

You can completely remove the link with a simple jQuery. This solution worked for me:

http://expectedexception.wordpress.com/2012/01/30/how-to-remove-the-list-view-web-part-title-bar-link/

1

Here's something I've used -- looks at each web part title, if it contains a link, the link is replaced with text:

$(function() {
    $('.ms-webpart-titleText').each(function() {
        var link = $(this).find('a');
        if (link.length > 0) 
            $(this).text(link.text()); 
    });
});
0

I think you are talking about a webpart property that needs to be changed. Edit the webpart properties, expand advanced and then clear out the text under Title Url.

1
  • 1
    That is correct, but clearing out does not work, it just reverts to the default. – mattruma Dec 1 '10 at 16:02
0
  1. Clearing out the text under "Title URL" only brings it back when you save.
  2. Adding a # creates a link to the existing page.

The native solution (without adding any external code) would be to modify your view and unselect "Title (linked to item with edit menu)" and select "Title" and move it up to its correct location.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.