10

I have created a very simple workflow that hard-codes some values into a dictionary, then writes the dictionary values to the status of the workflow.

When I publish and run it manually to my Sharepoint Online site (2013), it writes the first status, and then throws the following error: Activity in progress

Retrying last request. Next attempt scheduled after 8/6/2013 11:00 AM. Details of last request: HTTP Unauthorized to https://[site].sharepoint.com/_vti_bin/client.svc/web/lists/getbyid(guid'4bf18897-b58b-4316-a269-dc3902c90cc3')

I found an article online that told me to make sure Site Settings > Manage Site Features > Workflows can use app permissions is activated, but activating that feature didn't solve the problem.

Any idea what the problem is?

  • Have you solved this issue? Facing same problem now. – Serhiy Oct 28 '13 at 8:03
  • Yes -- I went through and confirmed that all Workflow-related features were enabled. I found one that wasn't (not the one mentioned above) and that solved the issue. – Josh Rogan Oct 28 '13 at 11:46
  • And in my case UPSA was not created. After I've created it - problem has gone. – Serhiy Oct 29 '13 at 6:45
  • I am having similar problems can you explain which features you had to enable? or what UPSA is? – Stephen Apr 15 '14 at 12:48
1

Apart from activating the feature, you'll also need to register workflow id in appinv.aspx for full effect to take place. Refer the below url to perfectly enable app step. Msdn link

-2

Make sure that "Workflows can use app permissions" feature in site feature is activated which allows workflows to read from and write to all items in your site.

  • It says right in the question, "I found an article online that told me to make sure Site Settings > Manage Site Features > Workflows can use app permissions is activated, but activating that feature didn't solve the problem." – adhoclobster Sep 17 '15 at 20:09
-2

I was in a similar situation where users with full control could run the workflow to completion, but contribute and under the workflow would end up cancelled. None of the common answers provided (App Step, App Permissions, User Profile sync Application, Applicaiton pool Settings, etc) worked for me.

The big issue was with the workflow configuration itself. Be sure that the "Automatically Update The Workflow Status To The Current Stage Name" box is unchecked in SharePoint Designer

The issue

Kudos to Paul Culmsee for the information Trials or tribulation? Inside SharePoint 2013 workflows–Part 3

In SharePoint Designer 2013, there is an option to disable the updating of stage information. In the workflow settings screen, look for the option called Automatically update the workflow status to the current stage name and untick it.

  • Please don't add the exact same answer to this question, as you did on this one. Instead, try to specify your answer further to make it a better of this specific question. Thank You! – Benny Skogberg May 1 '15 at 5:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.