4

Running a 2013 farm in RTM state right now...have several servers in the farm 2 WFE, 2 APP Servers, 4 Search Servers.

Been seeing these errors in my event logs and it's very random...sometimes it will be one server, another day it will be a totally different server...what generates this problem and what steps should i take to diagnose better. I can't seem to put my finger on what could be causing the problems. There isn't anything standing out that isn't working at the moment either that I could relate to these errors.

Error #1

A failure was reported when trying to invoke a service application: EndpointFailure

Process Name: OWSTIMER

Process ID: 2160

AppDomain Name: DefaultDomain

AppDomain ID: 1

Service Application Uri: urn:schemas-microsoft-com:sharepoint:service:1c0a6582c43f4c7a961104c7184b1f99#authority=urn:uuid:47cb52ff6db746d9b6030e6c3bf1b4fb&authority=https://nameofserver:32844/Topology/topology.svc

Active Endpoints: 1

Failed Endpoints:1

Affected Endpoint: http://nameofserver:32843/1c0a6582c43f4c7a961104c7184b1f99/SearchService.svc

Error #2

A failure was reported when trying to invoke a service application: EndpointFailure

Process Name: OWSTIMER

Process ID: 3428

AppDomain Name: DefaultDomain

AppDomain ID: 1

Service Application Uri: urn:schemas-microsoft-com:sharepoint:service:b1d71c1a38f943029c8fa60d337e50d3#authority=urn:uuid:47cb52ff6db746d9b6030e6c3bf1b4fb&authority=https://nameofserver:32844/Topology/topology.svc

Active Endpoints: 4

Failed Endpoints:1

Affected Endpoint: http://nameofserver:32843/b1d71c1a38f943029c8fa60d337e50d3/MetadataWebService.svc

Error #3

A failure was reported when trying to invoke a service application: EndpointFailure

Process Name: w3wp

Process ID: 64

AppDomain Name: /LM/W3SVC/2/ROOT/4ea30aebbf0f4ddb98fb7ab9e5c015ba-3-130166581631675817

AppDomain ID: 4

Service Application Uri: urn:schemas-microsoft-com:sharepoint:service:4ea30aebbf0f4ddb98fb7ab9e5c015ba#authority=urn:uuid:47cb52ff6db746d9b6030e6c3bf1b4fb&authority=https://nameofserver:32844/Topology/topology.svc

Active Endpoints: 1

Failed Endpoints:1

Affected Endpoint: http://nameofserver:32843/4ea30aebbf0f4ddb98fb7ab9e5c015ba/ProfileService.svc

  • 1
    We see these on our farm quite often, particularly with BCS. What time of the day do they appear? Any activity like iis reset or app pool recycle around those times. – Simon Doy Aug 5 '13 at 19:16
  • I took a look at things and i don't see a trend in IISresets or recycle events across the servers...it happens at random times during the day, sometimes very early morning, other times mid day, then other times in the evening... Do you guys have an understanding of what the error means? Have you been able to trace a resolution out? You running RTM? – Jacob A Aug 6 '13 at 18:14
  • 1
    We get them on SharePoint 2010 as well. Basically the topology service checks to see which servers are available to run the service application, the endpoint failures is when one of the servers fails to respond. – Simon Doy Aug 6 '13 at 20:23
  • 1
    I also have a farm where these errors randomly occur. I assume that this could be caused by limited server ressources, although we have 2 application servers with 12 GB of RAM each. I think as soon as memory exceeds, some webservices start to fail to respond. What do you think? – user21335 Dec 11 '13 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.