1

I am using a pre-workflow to move a document to an existing library after the recipient completes the task. Once it enters the new library I want it to automatically start the main workflow. Is this possible?

All workflows are already set to start when created and/or changed. I created the workflows in SharePoint designer 2013. The form that is being moved was made in infopath designer 2013.

Any ideas?

Thanks!

2

The scenario is as follows:
Source: Source Document Library
Workflow: Pre-Workflow --> It will move the document from Source Document Library to Target Document Library

Target: Target Document Library
Workflow: Main Workflow--> This is should execute once any document is getting created or updated by Pre-Workflow
Execution Policy: On Creation/Updation of Document in Target Document Library

Problem: Main Workflow is not getting executed by Pre-Workflow, once any document is getting created.

*

[Please correct me if the scenario is something else.]

*
Solution:

  1. If you run the Pre-Workflow using System Account, then Main Workflow will not be started automatically. So please start the Pre-Workflow using any other account than System Account. Log in to the site using other account than System Account
  2. If the Main Workflow is not getting executed after changing the log in account. Add a step in the Pre-Workflow by which you need to update a test metadata field in the newly created item in the Target Document Library. This step needs to be executed after copying of the document in the Target Document Library. By doing this the Main Workflow will be executed on change of the document.

Above solution should solve your problem.

0

Assuming that the 'main workflow' is attached to the new library and set to start upon creation of a new item, even if the new item is dumped in there via another workflow, the 'main workflow' should start without a problem.

  • The 'Main workflow' is attached to the new library, but it will not start unless I manually do it or change the item. Sharepoint does seem to recognize an item being dumped into library as "created". – Jason Jul 31 '13 at 19:43
  • And you are positive that the workflow is set to trigger when a new item is created? Is it a list workflow or a reusable workflow? I actually just finished a project where I am moving a completed Infopath form from one library to another and the destination library has a workflow that is set to trigger when the item is copied ove. – Mario Pereira Jul 31 '13 at 20:03
  • I'm using a list workflow. The "pre-workflow" is platform type: "sharepoint 2010 workflow" and the "main workflow" is platform type: "sharepoint 2013 workflow" if that matters. I need the exact same scenario as you have made and if can figure out whats going wrong, then i'll be done with my project also! Thanks for your help. – Jason Jul 31 '13 at 20:18
  • Did you make sure the 'main workflow' is set to trigger when a new item is created? Sometimes it's easy to forget! Also, just to be clear, which workflow is copying the item over to the new library? Are you using the Copy Item action? – Mario Pereira Jul 31 '13 at 20:31
  • The "pre workflow" will copy the item over once the task is completed like this : Step: Step 1 Assign From Accounting Department to Current Item:Account Id,--- Copy item in Current Item to Purchase Order Forms,--- Delete item in Current Item -------------------------------------------------- Once it copies over to "Purchase Order Forms" the workflow should start automatically. I made sure the "start when created was checked". Maybe if i disable the option to be start manually also, it may work. – Jason Jul 31 '13 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.