On my portal, I have setup User Profile Synchronisation and its working - actually syncing like a charm.

The problem is: one user still see the old email address when he tries to sign up for Alerts.

I went back to the user profile and verified the user data .. and within the user profile manager .. I see the correct email address.

Next I tried to change the email address again.. ran the synchronisation again... went back to User Profile Manager .. and the settings has been replicated from Active directory as expected... the only place that keep popping the old address is the Alert settings.

I hesitated before going to the database itself .. but I had no choice since google came with no help!

I ran a trace on the database .. and found some wierd stuff.

Actually the old address is still showing in the content Database under Alluserdata table. The column name called nvarchar4 (which is very helpful thank u microsoft !!!)

Before going this road and change it manually... I tought maybe someone had this similar issue.

2 Answers 2


I had that problem just the other day.

Here is how I fixed it: I went into Sharepoint Central Administration and ran the Full Synchronization job.

Then, I went into Active Directory and searched out the user. I discovered that I had the user tucked away into an OU that was not in the list of OUs that were scheduled to be synchronized.

http://YourSCA/_layouts/syncnow.aspx?ApplicationID=something or other enter image description here

So, you want to make sure to properly configure your Synchronization Connections - the link is in Sharepoint Central Administration > User Profile Configuration > Synchronization Connections. If you haven't created a connection, you need to do so, specifying the path to your Active Directory, the AD account with rights to edit the profiles there, and then choosing the OUs that you want to synchronize.

Sync icon

After all that is set up, then you need to run the Full Synchronization timer job. It will take about 10 minutes after that Full Synchronization for it to show in your Alert forms, but it will show!

  • Hi BGM,thanks for your reply , im sure the sync part is working ..i see the modification everywhere else except in the Alert form :S that said .. i ve tried to reinstall the userprofile service app again ... now im going to start a new web app/site create a new library .. just to verify if this think is really related to some mysterious cache/setting in the content database. thanks again
    – SunChero
    Commented Jul 31, 2013 at 13:22
  • I understand the issue - I had the exact same thing the other day. Whatever you do stay out of the sharepoint sql database everyone who is anyone will tell you that. Did you make sure that your Active Directory OU is set up correctly in the Synchronization Connections?
    – bgmCoder
    Commented Jul 31, 2013 at 15:34
  • as i said before .. tracing the database showed the old address are kept in the content database .. wich is related to the web application... i fixed my problem for the moment ..but im suspecting the fact that the users having problems were part of sharepoint groups i guess sharepoint will cache there users somewhere else. to be tested
    – SunChero
    Commented Aug 1, 2013 at 3:39
  • I know you said that - but if your synchronization isn't being done with Active Directory, then the data will never be gotten into Sharepoint unless you are creating a user in AD. The synchronization is how it gets from AD into SP's database. Sychronization of user profiles isn't based on groups - it's based on OUs.
    – bgmCoder
    Commented Aug 1, 2013 at 4:06

i just fixed this by deleting the user from the site collection and recreating his access sounds like there is a bug in propagating sync information from the userprofile application to the sharepoint application

  • When you create a new user, the data gets automatically propogated as opposed to synchronized. It would be better if you figured out how to get the synchronization working rather than recreating users just to make Alerts work properly. Your trick isn't a workaround - it's a momentary get-by maneuver and it isn't good practice - especially if you turn out later to have a high user volume.
    – bgmCoder
    Commented Jul 31, 2013 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.