0

I'm trying to embed HTML5/createJS in a SP Content Editor Web Part.

On my browser (Chrome):

enter image description here

In SharePoint (Chrome): The background CSS renders, but not the createJS/HTML5 elements (canvas):

enter image description here

Any thoughts?

Thanks

1

You have to change the browser mode in the masterpage, by default SP2010 forces the browser mode to IE8, you can change it to EDGE, but this way you will lose some default features like the rich text editor in the multiple line text boxes.

Change this:

<meta http-equiv="X-UA-Compatible" content="IE=8"/>

To this:

<meta http-equiv="X-UA-Compatible" content="IE=EDGE"/>
2

You can get it to work by modifying the masterpage, but things break and its probably not a good idea. However, having said that, there have been a few instances i have seen where guys are trying to get it to work

Have a look here for example. There is also a lot more out on the web.

  • I believe one of the things that will break is the People Picker control. – lgaud Jul 29 '13 at 15:40
1

SharePoint 2010 does not support HTML 5 or CSS 3.

  • I want to point out that even though this is true, it is only because the SP2010 default masterpage (v4.master) has a meta-tag which tells the IE browsers to run in IE8 compatibility mode. – user2536 Jul 29 '13 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.