0

I have a js calendar in our MOSS 2007 site. On the OnClick event of the button the calendar control comes up for the admin account. But it does not come up for all the other accounts. So when I checked the view source for admin I can see that it has all the tags needed for the calendar.

Admin account's view source:

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=utf-8">
<META Name="CollaborationServer" Content="SharePoint Team Web Site">
<script>
var navBarHelpOverrideKey = "wssmain";
</script>


<!--Included for javascript calendar--start-->
<link type="text/css" rel="stylesheet" href="../../_catalogs/masterpage/_layouts/STYLES/CalendarCss/jscal2.css" /><link type="text/css" rel="stylesheet" href="../../_catalogs/masterpage/_layouts/STYLES/CalendarCss/border-radius.css" />
<!-- <link type="text/css" rel="stylesheet" href="../../_catalogs/masterpage/src/css/reduce-spacing.css" /> -->

<link id="ctl00_skinwin2k" title="Win 2K" type="text/css" rel="alternate stylesheet" href="../../_catalogs/masterpage/_layouts/STYLES/CalendarCss/win2k/win2k.css" /><link id="ctl00_skinsteel" title="Steel" type="text/css" rel="alternate stylesheet" href="../../_catalogs/masterpage/_layouts/STYLES/CalendarCss/steel/steel.css" /><link id="ctl00_skingold" title="Gold" type="text/css" rel="alternate stylesheet" href="../../_catalogs/masterpage/_layouts/STYLES/CalendarCss/gold/gold.css" /><link id="ctl00_skinmatrix" title="Matrix" type="text/css" rel="alternate stylesheet" href="../../_catalogs/masterpage/_layouts/STYLES/CalendarCss/matrix/matrix.css" /><link id="ctl00_skinhelpercompact" type="text/css" rel="alternate stylesheet" href="../../_catalogs/masterpage/_layouts/STYLES/CalendarCss/reduce-spacing.css" />

<script src="_layouts/CalendarJS/jscal2.js"></script>
<script src="_layouts/CalendarJS/unicode-letter.js"></script>

<!-- this must stay last so that English is the default one -->
<script src="_layouts/CalendarJS/lang/en.js"></script>

<link type="text/css" rel="stylesheet" href="../../_catalogs/masterpage/_layouts/STYLES/CalendarCss/demopage.css" />
<!--Included for javascript calendar--end-->

<style type="text/css"> 
.zz1_TopNavigationMenu_0 { background-color:white;visibility:hidden;display:none;position:absolute;left:0px;top:0px; }
.zz1_TopNavigationMenu_1 { text-decoration:none; }

But when I login as any other user the whole set of tags are missing as follows.

Any other account's view source:

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=utf-8">     
<META Name="CollaborationServer" Content="SharePoint Team Web Site">
    <script>
    var navBarHelpOverrideKey = "wssmain";
    </script>
 <style type="text/css">
    .zz1_TopNavigationMenu_0 { background-color:white;visibility:hidden;display:none;position:absolute;left:0px;top:0px; }  .zz1_TopNavigationMenu_1 { text-decoration:none; }

This is really weird and am not able to find out why this is happening. Will be happy to receive any help on this.

Thanks, Carolina

0

Tried checking in the master page as a major version and approved it in the site's master pages gallery. Then the calendar came up for all users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.