1

How can I get my login account to not show as [System Account]?

I've setup up SharePoint locally on my system as standalone environment, using my windows credentials [Domain\Username] to set it up.

Everything is working perfectly fine except one thing which is as soon as I any access any site / CA, I am logging in as SharePoint\System [System Account].

But I want it to show as my local account and not the system account.

  • I have already checked that [SharePoint Central Administration v4] application pool is running on my local account[domain\username].
  • [Web Application -80] app pool is running on Network Service account & [SecurityTokenServiceApplication] app pool is running on LocalSystem.
  • Also, within central admin's farm administration section, I have removed my Local account [domain\username].

I have read a lot of technet and msdn articles on it & it states that this could be happening because of various reasons.

  • So, what exactly is your question? You should break up your paragraph some more because it is difficult to read. – bgmCoder Jul 25 '13 at 14:10
  • Setup up SharePoint locally on my system as standalone environment. Used my windows credentials [Domain\Username] to set it up. Everything is working perfectly fine except one thing which is as soon as I any access any site / CA, I am logging in as SharePoint\System [System Account]. Which is the issue. I dont know how to seperate my account so that it cannot appear as system account – user1826 Jul 25 '13 at 15:24
  • I cleaned up your question for you. – bgmCoder Jul 25 '13 at 15:51
1

The System Account is the one you specified in Sharepoint Central Administration as the Farm Administrator. It will always show as [System Account].

I created for myself a separate user account with full rights and use that account instead.

Here are some similar questions with answers (here on SSE):

0

The above is true in a complete farm setup! In my case, I have sharepoint 2010 setup on my local win 7 machine. Which dont allow provisioning user profile services also no access to AD and above that it uses SQL Express. because of this setup whenever I provisioned a new web application using my domain/windows username, it reflects as SYSTEM ACCOUNT. Thou app pool acct was Network Service the farm admin account was using my username. Therefore the avoid this, i have re-provisioned the web app using Network Service acct. Which resolved my issue. TX.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.