0

I have been following the following for configuring an app domain in our SharePoint 2013 environment. When I reach the step for New-SPSubscriptionSettingsServiceApplicationProxy, I am getting the following error:

New-SPSubscriptionSettingsServiceApplicationProxy : A
SPSubscriptionSettingsServiceApplicationProxy with id
'4f0c42b1-5288-4057-8686-97464082df9b' already exists. Only one can exist per
farm.
At C:\Users\spfarm10\Desktop\Set_App_Domain.ps1:19 char:16
+ $proxySubSvc = New-SPSubscriptionSettingsServiceApplicationProxy

What would be the best method for resolving this error?

Setting up App Domain for On-Prem Deployment

Error Occured in Deployment Step of App

1

After more digging and testing, this error originated from the SharePoint environment not having access to the internet to verify certificates. This causes us to try numerous time to configure different services, most of which resulted in errors, or the creation of multiple services and proxies.

The server was temporarily granted access to verify the certificates, and the excess service applications were removed. The I was able to create the App domain, which was the end goal.

This may or may not have been the best approach, but in this case, it worked.

| improve this answer | |
0

Looks like you already have a subscription service and proxy, try to skip those two lines and continue with the app proxy and so on

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.