I'm going through the steps to create a site collection but after I created it, I can't access it via "intranet.contoso.com". I keep getting the error "Internet Explorer cannot display the webpage".

Things I've tried:

  • Disabled loop back checking
  • Added to the host file
  • Restarted IIS
  • Flushed DNS

I'm not really sure what else to do. When I tried to ping the host (intranet.contoso.com) it times out. This is what I have in the display all site collections.

For some reason the option to create a new web application is greyed out so I can't even start from the beginning unless I role back the VM's which I don't really want to do.

  • Have you checked for the Application Pool. – Pushpendra Jul 24 '13 at 16:43
  • i.imgur.com/ltFElOe.png I went into it before and noticed "SharePoint Web Services Root" was off so I turned it on but it didn't help. – Batman Jul 24 '13 at 17:29
  • I won't ideally recommend..but let's restart VM if possible. I am unable to figure out the issue. Also try accessing the site and central admin with Application pool A/C. Also check the managed path. – Pushpendra Jul 24 '13 at 17:35
  • I've restarted the SP Server VM a few times but not the SQL server. The SQL is on it's own VM. I'm not sure what you mean by Application pool A/C. I went to managed paths and this is what I got i.imgur.com/gZPi3Gg.png – Batman Jul 24 '13 at 17:47
  • Pls share the webapplication list of your server. As I can see the Managed path is correct. Application pool A/C is the the account with which your application pool is running. blogs.msdn.com/b/modonovan/archive/2005/06/14/428862.aspx – Pushpendra Jul 24 '13 at 18:06

I guess I got the problem at your end. You have set the url for your web app as http://interanet.contoso.com. Now this DNS mapping is not correct as it does not exist on your server.

You must not have changed it. When you would have created Sharepoint would have set the default value http://sp2010-wfe:80 initailly.
Since the Central admin url for you is http://sp2010-wfe:1433

So two approches are there either update the web app url through powershell or create a new one with the default url.

MSDN update wep app url

| improve this answer | |
  • So the problem is that my central admin is at port 1433 instead of 80? – Batman Jul 24 '13 at 18:31
  • no...I got me wrong no problem with Central Admin. You assigned interanet.contoso.com this url for ur web app is mistake. I guess you got it from MSDN. This must be sp2010-wfe:80 – Pushpendra Jul 24 '13 at 18:34
  • so intranet.contoso.com should be changed to sp2010-wfe:80? Why would that be the case? – Batman Jul 24 '13 at 18:37
  • It seems that you should know more about DNS maapping. Tell me how the IIS will know contoso.com is hosted on your machine...? Okay so just do one thing modify your hosts file. It is loacted at C:\Windows\System32\Drivers\etc Open the host file with notepad and add the following line at the end your VM IP interanet.contoso.com Save the file and check – Pushpendra Jul 24 '13 at 18:42
  • When I created the site, I set the ip to I've taken that and intranet.contoso.com to the host file but that didn't help. – Batman Jul 24 '13 at 18:46

In IIS have you checked to see if the Default web site is stopped?

| improve this answer | |
  • It says "restart" so I assume it's on. But it has a question mark on the Globe Icon. I'm not sure if thats a bad thing or not i.imgur.com/Yk4DY3W.png – Batman Jul 24 '13 at 17:31
  • Your graphic indicates your Default site is running. Click stop on the right under Manage Website. It is handling the web traffic. That's why it is not getting to contoso.com – MonkeyWrench Jul 24 '13 at 20:07
  • I turned it off but it didn't help. Like another user asked me to try to do it using only default values and it worked fine but when I try to give it a name or change the host header, won't work. – Batman Jul 24 '13 at 20:45

Did you double check your managed paths? Is that still showing the path to the site collection that you wanted to place there?

| improve this answer | |
  • I haven't checked that, i'm not really sure what that means. – Batman Jul 24 '13 at 17:31
  • I looked into it and see this i.imgur.com/gZPi3Gg.png I clicked "Check URL" but nothing resolves. – Batman Jul 24 '13 at 17:41
  • can you try to add a new path, (explicit) and then go to App management and create a new site collection on that managed path and then see if you can navigate to the site. – Chris Jul 24 '13 at 18:05
  • yea I'll give that a shot, the new managed path, do I give it a random name? – Batman Jul 24 '13 at 18:10
  • well if you're just testing stuff for now then it doesn't matter, but that will be the URL to your site (//server/managedpathname/) – Chris Jul 24 '13 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.