I've been investigating an issue recently where the system/farm account received Native Code HRESULT Access Denied exceptions from SPRequest trying to access several folders in a large list.

Deep analysis shows that there are about 200 thousand items separated in folders according to recommendations and there are about 670 unique permissions in the site collection and 6 (six) SPFolders have NULL Permisions assigned according to the TVF used there (by ScopeId).

[Update] 500 INTERNAL SERVER ERROR is rendered when browsing to these folders [/Update]

The 6 SPFolders appear to have NO permissions assigned: looked into a copy of content DB table Perms and view Docs where left-joining by ScopeId gives NULL on the Perms side. Actually there are matches in Perms where Perms.ScopeUrl = Docs.DirName+'/'+Docs.LeafName but ScopeIds differ.

How should I get on with it?

3 Answers 3


You could try setting a web application policy to give yourself (or someone else) permissions and then browse to the folders to set the proper permissions on it.

  • Hi, Mirjam, I tried that before and I tried it again after your suggestion. It doesn't work. Nov 26, 2010 at 3:48
  • And welcome to SPOverflow! Nov 26, 2010 at 4:11

I've experienced the same problem a year ago with combination large library + lot of permissions and pretty much just gave up. I suggest calling MS for support on how to do this, perhaps they can fix the database.

P.S. I Tried evertything permission wise and nothing helped, not even logging as the service account for the app pool itself.


It was a while ago, and the database was already unsupportable, but we fixed it by finding the scopes with missing perms or vice versa in a backup and resetting the ACL to that of parent container with a SQL UPDATE query. As this is unsupported, any further details could only be provided privately.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.