3

I've created and published my form in DEV environment. For testing, I have published it to the Test environment. I used the following technique and now the forms are working fine.

  1. Saved the source files out in InfoPath client.
  2. Edited the manifest file with the correct URLs.
  3. Saved and published back into SharePoint.

I have nearly 50 infopath forms and I cant use the above technique in PROD location, because this is time consuming method.

Is there anyother technique or code or script or tool to do it with less span of time.??

1
2

I've been through this pain. This PowerShell command is the key:

Get-SPWebApplication http://contoso2010 | Update-SPInfoPathUserFileUrl -find "http://contoso2007" -replace "http://contoso2010"

Microsoft reference here: http://technet.microsoft.com/en-us/library/ff607651(v=office.15).aspx

2

After a long research, I found the below for modifying the url of the SharePoint site used for fetching the data:

  1. Open the xsn file in design mode
  2. Go to File-> Pubish -> Export Source Files. A folder will be created with manifest file
  3. Open the manifest file and change the url (as per your requirement)
  4. Save the manifest file and then change the extension to .xsn of the manifest file
  5. Open in design mode and check the data connections.

Problem will be resolved.

1
  • Hi I am dealing with a similar situation. I followed the above steps but i can't change the 'Main Data Connection'. Can you explain how can the main data connection be changed to reuse the form template at different sites? – Noman Farooqi Jan 3 '17 at 19:02
1

You may want to set up Universal Data Connections (UDC) with relative URLs. UDCs are stored in a Data Connection Library of the site or site collection. Let all data connections in your InfoPath forms refer to UDCs instead of absolute URLs.

When you set up the data connection options, you can select the "Local data connection library", which will retrieve settings from a data connection library in the same site collection as the form.

enter image description here

4
  • Hi Thanks for your reply, I have implemented UDC's only, but the problem is, when i move the site collection from Development to Test environment, the data connections in the infopath forms are pointing to the development environments--> Data connection libraries UDC files. – Karthik Jaganathan Jul 29 '13 at 9:09
  • To resolve this, I got to open the infopath form's manifest file and replace the "URL" of development environment's Data connection library with the test environment's data connection library URL. I got to do this for all the 50+ infopath forms and republish. This is my problem. – Karthik Jaganathan Jul 29 '13 at 9:11
  • Sounds like the URLs are absolute, not relative. – teylyn Jul 29 '13 at 9:35
  • Hi Teylyn, In the InfoPath forms its shows, Connection Source: Development Environment URL (Link Type: relative). – Karthik Jaganathan Jul 29 '13 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.