I've uploaded .swf files to a document library and the jwplayer.js file to the same library. From there I've uploaded an HMTL file which contains:

<script src="//ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>

 <div id="mediaplayer">Loading video...</div>

 <script type="text/javascript" src="https://domain.com/external/Media/jwplayer.js"></script>
 <script type="text/javascript">
   flashplayer: "https://domain.com/external/Media/jwplayer.flash.swf",
   file: "https://domain.com/external/Media/test1.swf",
   image: "http://oyster.ignimgs.com/wordpress/stg.ign.com/2013/03/WorldWarZ-Poster.jpeg"


But instead of playing the file it tries to download it everytime the page loads and the player never shows up. I tried using this guide but i'm not sure what the problem is.

  • This may be better asked on the LongTail forums longtailvideo.com/support/forums or StackOverflow - there could be an issue with your mixed content. When posting in either place I recommend you add a bit more detail as to what you have done (renamed files, edit JS file, etc). – Jesus Shelby Jul 18 '13 at 20:35

In Central Administration, go to Manage Web Applications and select the web app you're working with and then General Settings from the ribbon.

In the Browser File Handling option choose Permissive.

Specifies whether additional security headers are added to documents served to web browsers. These headers specify that a browser should show a download prompt for certain types of files (for example, .html) and to use the server's specified MIME type for other types of files.

Permissive Specifies no headers are added, which provides a more compatible user experience.

Strict Adds headers that force the browser to download certain types of files. The forced download improves security for the server by disallowing the automatic execution of Web content that contributors upload.

| improve this answer | |
  • 2
    Good Suggestion on that, however I don't recommend doing this thru the UI, it's an all or nothing affair. Instead use the "AllowedInlineDownloadedMimeTypes" via Powershell or code to set the Mime Types individually. – Jesus Shelby Jul 19 '13 at 2:58
  • Excelent suggestion Jesus! – Luis Jul 19 '13 at 8:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.