I have a SharePoint 2010 single instance. The Web site has an Excel worksheet in Shared Documents, which I can navigate to as a user.

  • I have enabled Excel services.
  • I have activated Excel services proxy.
  • The Web application is associated with the Excel Services service application (through Central Administration --> Application Management --> Configure service applications associations.)

Remotely I can Check Out the Site Page, edit the Site Page, edit the WebPart. Here I select the WorkBook through the elipsis button on the properties of the WebPart. Everything seems good at this point, as I can find the Workbook easily this way.

When I click "Apply", I get the error message:

"The file that you selected could not be found. Check the spelling of the file name and verify that the location is correct. Make sure that the file has not been renamed, moved or deleted."

I also get this error message when I simply navigate to Shared Documents remotely.

NOTE: When I copy the URL of my worksheet from the WebPart property, Workbook, to a browser, I can open the file after an authentication challenge.

1 Answer 1


Excel services will only work with spreadsheets that are in a trusted location - you can set trusted locations in the Excel Services settings in Central Admin.

  • What do you mean? The spreadsheet is in the Shared Documents of the same SP Site?
    – Blanthor
    Commented Jul 17, 2013 at 20:48
  • In CA you define which sites/libraries are trusted locations - just because it is in SharePoint does not necessarily mean it is in a trusted location. Commented Jul 17, 2013 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.