0

We are facing strange issues with my custom web part. This web part is embedded on the page and whenever user tries to access this web page first time in a day he gets "403 Forbidden error" then he clicks browser back button and web page loads perfectly with web part. Afterwards whole day this problem never comes. It happens same way again from next morning.

User has full control on the site so I don't see any such permission issue. This web part reads documents from multiple lists and display on data grid. User has full control permission on all the lists so it's also fine. I tried to comment the web part code and still he gets forbidden error when he logins first time.

I don't know what else I should look for .. Any help will be much appreciated.

Note: It's not just dev machine but it's happening on prod server as well. Also, It's not for one but happening for many users.

1 Answer 1

0

Not sure but Pls confirm for any timer job which might be creating this kind of problem.

5
  • NO such timer job. It's visual web part with C# code.
    – Rishi
    Jul 16, 2013 at 14:48
  • I mean to say any other time job deployed on your server. Again not sure but just cross check the things.
    – Pushpendra
    Jul 16, 2013 at 14:52
  • Yup there is a time job which belongs to some other app.
    – Rishi
    Jul 16, 2013 at 14:59
  • Then just check if that timer job is creating and kind of problem.
    – Pushpendra
    Jul 16, 2013 at 15:00
  • Timer job is fine though. Don't see the reason how forbidden error disappears after first time and never comes back again for whole day.
    – Rishi
    Jul 16, 2013 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.