I'm trying to solve this "File not found" error by digging through the ULS logs for more information, but there's no exception recorded for the correlation ID on the error page. I've set every category to report errors from Verbose upwards in central admin, but for the correlation ID all I see in the logs are a few entries regarding the connection to the user profile service, and no information about what file cannot be found.

Are there any more logging settings that I've missed, or is it a bigger issue if this sort of thing isn't logged?

Update Entries in the ULS for the displayed correlation ID. These are the only entries, no Exceptions or Warnings:

Process |Product              |Category  |Level  |Message
w3wp.exe|Sharepoint Foundation|Logging   |Verbose|Starting correlation.
w3wp.exe|Sharepoint Foundation|Topology  |Medium |WcfReceiveRequest: LocalAddress: 'http://[webapp]/[guid]/ProfileDBCacheService.svc' Channel: 'System.ServiceModel.Channels.ServiceChannel' Action: 'http://Microsoft.Office.Server.UserProfiles/GetUserData' MessageId: 'urn:uuid:[guid]'
w3wp.exe|Sharepoint Foundation|Monitoring|Verbose|Leaving Monitored Scope (InitializeWcfServerOperation). Execution Time=0.118450808692166
w3wp.exe|Sharepoint Foundation|Monitoring|Verbose|____Execution Time=0.118450808692166
w3wp.exe|Sharepoint Foundation|Monitoring|Medium |Entering monitored scope (ExecuteWcfServerOperation)
w3wp.exe|Sharepoint Foundation|Logging   |Verbose|Starting correlation.
w3wp.exe|Sharepoint Foundation|Logging   |Verbose|Ending correlation.
w3wp.exe|Sharepoint Foundation|Logging   |Verbose|Ending correlation.
  • 1
    When is a 404 not a 404? When it is a content database that isn't providing the information. If you do have some log lines look at the Exceptions and Warnings of those lines from the correlation ID and see what is there. If you are unsure post them on here for analysis. (In the original thread edit your post to do so)
    – Hugh Wood
    Commented Jul 15, 2013 at 12:59
  • Added. I was expecting to see an Exception entry for the error, but there's been nothing.
    – MorayM
    Commented Jul 15, 2013 at 16:04

3 Answers 3


This error is actually a unauthorised from within the managed code of the owssvr.dll.

This coming up with 404 because the server is making receiving the request on it's wcf service.

Browse to the address given on the local address part:


Then confirm access to this web service. It is the proxy service for the User Profile Service. If you do have access, check to make sure the users who are accessing this data have correct permissions in Central Administration to the User Profile Service and Administration permissions where required.

This error will occur more often if you are making a call to a UPS service through code locally and through perhaps Run With Elevated. If this is the case make sure you are adding the application pool user to the permissions to read/write when needed.

The reason you cannot see the exception is because it is on a different correlation ID as it is a request to the server basically meaning there are multiple requests going on here. Locate the correlation ID in ULS viewer with the filter, select it and turn off the filer and pause. When you scroll up and down from that location you should see the error if you still have verbose on, I would potentially put on verboseex (Powershell command line to do this) so you can get the stack trace.

  • Thanks for the great suggestions Hugh, but the problem turned out to be a lot simpler. For anyone else reading this, verbose logging is turned on using Set-SPLogLevel -traceseverity verboseex and WCF service debug information can be viewed by adding <serviceDebug includeExceptionDetailInFaults="True" /> in the <behavior> tag of the service's web.config. Turned out to be helpful in solving some other problems I've been having.
    – MorayM
    Commented Jul 17, 2013 at 13:48

In this case, the reason the logs were so empty was because only one of my SharePoint system accounts had permissions to write to them!

To fix this, I added the various system accounts for the Farm, Search and Crawl services, App Pools etc. to the [domain]/Builtin/Performance Log Users group in Active Directory and restarted the server.


I was facing the same error. Make sure the solution you have deployed must have called the profile service internally.

Deactivation and then activation of the custom features worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.