2

Using SP 2010 and SPD 2010, I've found the problem: when I try to open page in Designer (using Site Actions -> Edit in Sharepoint Designer), it doesn't open, but there is popup window with invite to load Sharepoint Designer. But SPD is installed. How to fix it?

marked as duplicate by Robert Lindgren, Benny Skogberg, Eric Alexander, RJ Cuthbertson, Jesus Shelby Jul 16 '13 at 22:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • can you open the page from designer? – Jesus Shelby Jul 14 '13 at 17:06
  • @Jesus Shelby, yes, I can. – Max Zhukov Jul 14 '13 at 17:09
  • I guess you are using Internet Explorer? – Robert Lindgren Jul 14 '13 at 17:11
  • @Robert Lindgren, I used IE and Chrome. – Max Zhukov Jul 14 '13 at 17:40
  • @Robert Lindgren, thanks a lot! Sorry for duplicate question. – Max Zhukov Jul 14 '13 at 18:27
1

Have you enabled SPD on your Web Application in Central Administration, and have you enabled the use of SPD on the site collection your wording on, and have you at least design permission on the site you want to edit?

Reference: Manage Permissions and Control Access to Sharepoint Designer

  • yes, everything is enabled, and my permisson level is farm administrator. – Max Zhukov Jul 14 '13 at 15:56
  • @MaxZhukov Is your farm admin site collection owner? If not, what privilege does your farm admin have on the site/page your trying to edit? – Benny Skogberg Jul 14 '13 at 16:27
  • yes, I'm site collection owner, it's development server. I suppose that the problem isn't in permissions. Is there any binding between SP Server and SPD? Maybe my SP Server can't find designer? But I can run SPD from windows... – Max Zhukov Jul 14 '13 at 16:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.