2

I have enabled the Document ID Feature, and it works just fine; in the document library, I can have a view showing the IDs. However, the ID is not visible when I check the document properties, and it's not visible if I open a Word document and try to insert the field.

There is no Document ID column visible in the library, or in any content type (it's supposed to be automatically added to Document). We have SP 2013 Server, English, with a Swedish language pack installed.

2

Since the Document ID column is auto assigned, it is not editable, and will not show up under edit properties or as a document property in office. This is the standard behavior, so you are not missing any configuration.

  • I know it's not editable, but it does show as a document property when I make a new library using only content typ "document". It thought my custom content type, which is based on document, should inherit the Document Id, but obviously it doesn't. I wonder if the fact that I am using a Content Hub that messes things up? Or is it the Swedish language pack that is causing the problem? – Klas Eckerberg Jul 15 '13 at 9:36
  • There are 3 columns added to Document content type when you activate the Document ID feature on a site - all of them are flagged as hidden, so despite being on the content type you will not see them - msdn.microsoft.com/en-us/library/ee559302(v=office.14).aspx – Chris Beckett Jul 20 '13 at 7:29
  • If you are distributed with the content type hub, you must ensure that the Document ID feature is enabled on the hub site collection, and also on every target site collection that subscribes as well. – Chris Beckett Jul 20 '13 at 7:34
  • If you create a custom content type that inherits from Document, the child will inherit the Document ID columns as well. I suspect that the fields are being dropped from the content type when it is replicated from the hub because the Document ID service is not enabled on the target. – Chris Beckett Jul 20 '13 at 7:37
0

The content type that is being displayed on View Properties should inherit "Document Id" field. In case, for some reason, if this is missing, the "Document Id" field won't be visible. We can add this back using Server Side API. Goto the ContentType (Hub CT or list CT doesn't matter) add all the "Document Id" related fields using FieldLinks property. The changes made to the CT here are scoped to that list only.

The assumption is the "Document ID" field is already available in the list but just not showing up in the document properties.

     $ct = $list.ContentTypes["your content type name"]
     $ct.ReadOnly = $false
     $spDocIdField = $list.Fields["Document ID"] #Ideally adding this field is enough to see the document id in view properites
     $ct.FieldLinks.Add($spDocIdField)
     $spDocIdField = $list.Fields["Document ID Value"]
     $ct.FieldLinks.Add($spDocIdField)
     $spDocIdField = $list.Fields["Persist ID"]
     $ct.FieldLinks.Add($spDocIdField)
     $ct.ReadOnly = $true
     $ct.Update()

In other words, this is kind of replicating a field to "Add to All Content Types" functionality when introducing a new field in the list.

Option 2:

The OOB way to fix this issue is republish the content types and re-run the CT Hub sync and Doc Id timer jobs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.