2

I am facing some weird issue during the custom farm solution deployment in staging. I am receiving below error when activating the one of the features which deploys custom managed metadata fields as site columns.

the error is :

The local device name is already in use. (Exception from HRESULT: 0x80070055)

Digging into the ULS log, I gave the below details.

Unable to locate the xml-definition for FieldName with FieldId 'b1688cb4-a3a9-4044-9dc8-286705012a42', exception: Microsoft.SharePoint.SPException: Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED)) ---> System.Runtime.InteropServices.COMException (0x8000FFFF): Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))    
 at Microsoft.SharePoint.Library.SPRequestInternalClass.GetGlobalContentTypeXml(String bstrUrl, Int32 type, UInt32 lcid, Object varIdBytes)    
 at Microsoft.SharePoint.Library.SPRequest.GetGlobalContentTypeXml(String bstrUrl, Int32 type, UInt32 lcid, Object varIdBytes)     -
-- End of inner exception stack trace ---    
 at Microsoft.SharePoint.SPGlobal.HandleComException(COMException comEx)    
 at Microsoft.SharePoint.Library.SPRequest.GetGlobalContentTypeXml(String bstrUrl, Int32 type, UInt32 lcid, Object varIdBytes)    
 at Microsoft.SharePoint.SPFieldCollection.FetchFieldsFromWeb()

I have tested this solution package in dev and test environments. It has provisioned the managed metadata field along with the SharePoint hidden field as expected.

In Google, People are suggesting to try below things

  1. change the guild’s of these fields (I can’t do in my scenario as has some dependencies )
  2. Guid’s should have {} braces (true in my case)
  3. Add attribute “Overwrite=”TRUE”” (already added in all the fields)
  4. Guid’s with same ID already exists ( checked not in this case)
  5. Stop-Start the managed metadata service (tried but no luck)
  6. Check Content database "ContentTypes" "ContentUsages" tables ( which I did and made sure that the fields are clear and not there)

also I have tried reboot and IIS reset on the app server but no luck.

my question is , Where SharePoint is holding a reference to those fields , after deleting cleaning the fields even from SharePoint database?.

1

DO NOT CHANGE Recycle Bin settings!

It has nothing todo with it!

obviously the first part that i would do is change your guid to somthing else!

SharePoint has detected a duplicate Guid. Change the Guid and try again

Content Type Feature Activation nativehr 0x80070055

if that is not an option! than you need to start from scratch! You need to remove the solution and perform an iisrest after each comman, Once you have removed your custom farm soultion again perform iisreset. Add the solution and at the end do an iisreset!

another solution as this person has solved from the error you have give in uls:

•Make sure your GUIDs have brackets around them •Make sure the ListUrl attribute of your ContentTypeBinding element matches your ListInstance Url attribute

http://blog.stilldesign.co.nz/2010/9/19/Unable-to-locate-the-xml-definition-for-FieldName-with-FieldId-e28098IDe28099

the above should solve your issue!

| improve this answer | |
0

Have you tried swiping out the Recycle Bins? This happens quite often when developing Content Types and Site Columns through CAML. On my development environment I usually turn off Recycle Bin at the Web Application level. Navigate to Central Admin => Application Management => Manage Web Applications => Select Web Application and click on General Settings. At the bottom turn off Recycle Bin. Try to deploy again.

Note that turning off the Recycle Bin is not recommended for production and staging environments.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.