0

I often get this message when I use a column that is a taxonomy field. Sometimes it works if the list is empty and I re-apply my custom created content type, but sometimes it doesn't. Anyone have any suggestions? This happens in SharePoint GUI.

I should clarify that I get the message when I try to save an item.

marked as duplicate by Robert Lindgren Nov 27 '13 at 9:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I don't think it's a throttling issue since I only use one taxonomy field. – user14656 Jul 8 '13 at 14:06
0

IF everything has been setup properly:

  • Added an extra note field to the schema.xml for each Taxonomy field
  • Changed the throttling settings

AND everything stated in this article is clear and okey-dokey:

http://tjendarta.wordpress.com/2013/07/16/fix-the-splistitem-being-updated-was-not-retrieved-with-all-taxonomy-fields/

then I would suggest to check this:

  • open site collection content type using SharePoint Web Interface:
  • site settings
  • site content types
  • open the content type
  • In the Columns list open the column giving the error
  • Modify site column
  • Edit the term set column setting
  • save
  • Great answer. Saving the columns did the trick for me – Drkawashima Aug 5 '15 at 13:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.