11

So I'm wondering if this is a bug or not.

I have an ordinary Wiki Page, also tried making an Article Page.

Once this page is made, I add an XsltListViewWebPart that points to a list, which is fine, this is added from the sharepoint web site page edit.

When I open it up in Sharepoint Designer 2013, and select the XsltListViewWebPart the ribbon does not contain the List View Options listview for me to edit the filters, parameters etc.

enter image description here

What I do notice is, when I add the XsltListViewWebPart from inside the Sharepoint Designer 2013, I see the ribbon section fine. However once I save changes on the page, close it and re-open it, same issue, can't see that ribbon section.

Anyone know why?

  • SharePoint Designer has always been one of the worst embarrassing piece of crap I've ever had the misfortune to work with. I've lost count of the bugs I have encountered since I started using it. To add something to the issue you reported (which I can confirm is vexing me as well), what about if you add a XsltListViewWebPart (which fires open the List View Tools), then point the mouse cursor right after the t of the WebPartPages:XsltListViewWebPart tag and press Enter. Any of the buttons on the List View Tools ribbon group won't work anymore (will get greyed out). They must be kidding. – MdMazzotti Apr 16 '14 at 12:51
17
+200

I can't really provide a sensible answer to why this is happening (I can confirm I'm experiencing the same weird behavior. I'm sure this is related to the fact that they cut out the designer part without properly thinking about the consequences this would have had).

What I can offer is a dirty workaround that proved to be almost always working in my case. As you can see from the screenshot below, I'm starting on a page with a XsltListViewWebPart. Clicking on the tag or within it doesn't make any difference and the result is that the List View Tools is simply not shown.

enter image description here

Here's the trick: Position the mouse over the WebPartPages:XsltListViewWebPart tag and right click, then click Tag properties (or alternatively, on the bottom right of the screen, click on the breadcrumb <WebPartPages:XsltListViewWebPart> part, then click on Tag properties). There is no need to change anything, just click on the OK button. The List View Tools ribbon group will immediately show up.

You will need to repeat the steps above every time you re-open the page and need to edit the webpart again.

Here's the same page, right after having clicked on the OK button. enter image description here

  • A dirty work around for a filthy product! It had to take one extra step - after clicking OK on properties dialog I had to click somewhere inside WebPartPages:XsltListViewWebpart tag again to make ribbon tools available. – Ryan Apr 16 '14 at 21:46
  • Can't award bounty for another 13 hours but will do as soon as time up. – Ryan Apr 16 '14 at 21:46
  • 1
    @Ryan another option would be to stick to using SPD2010 even when targeting a SP2013. Apart having to uninstall some Office updates to make it work without complaining about alleged "incompatibilities", I still haven't found a single reason to use the latest version – MdMazzotti Apr 16 '14 at 21:48
  • 1
    I've written up these with a short video blog.pentalogic.net/2014/05/… – Ryan May 30 '14 at 10:49
2

This is the best and shortest solution

Go to Edit web part and select "Miscellaneous" property and click on Server Render checkbox.

then you will able to see that in designer

hope it helps!

  • This is definitely not the "best". Forcing the Server Render to true has some negative effects (on Tasks view webparts, it disables the Timeline and Complete icon functionality). My solution it's just a trick and you don't need to change anything. Moreover, also with yours, when you close and re-open the page, the List View Tools tab won't show up anyway (and you still have to repeat the process) – MdMazzotti Apr 17 '14 at 13:05
  • i dont think you have to reopen the page everytime. and as far as reopening is concern, even with your method, if we change style in design tab, you dont have to open it everytime.but your method was also a good trick. – SharePointMan Apr 17 '14 at 16:26
  • It's not that you have to reopen it every time. If you need to reopen the page for some reason and edit the webpart again, then you must repeat the steps above – MdMazzotti Apr 17 '14 at 16:30
  • The reason we dont see that tab is because of rendering.if you dont believe this than change the style in design tab with your method and save it..even if you have to do something with the webpart next time, you dont have to follow your procedure next time. with server render, i dont know what you are saying is true or not but definetly you dont have to follow your steps for sure – SharePointMan Apr 17 '14 at 16:34
  • Look, I don't really want to start a pointless flame on this. If you're happy with your workaround, stick to it (I tested just now, and it's not working on my environment. Upon page close and reopen, even after having changed the style, the List View Tools tab doesn't show up). There shouldn't be the need for this dirty hacks at all, this is the real matter. – MdMazzotti Apr 17 '14 at 16:44
0

Don't worry about this, Just do a little trick that's work fine for you to show LIST VIEW TOOLS option, Open your page in SharePoint Designer and find end tag of XsltListViewWebpart that looks like: < /WebPartPages:XsltListViewWebPart>

Just click anywhere in this end tag on your page the LIST VIEW TOOLS option will appeared.

See attached before and after images: Before Image-> enter image description here

After image-> enter image description here

I hope this will help you...

  • When I select the tag, the tools don't come up, the tag does not appear at the bottom of the page, and if I right click on the tag, and open up "Tag Properties", it opens up the "Page Properties" dialog. – cbbrown Aug 4 '17 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy