1

After installing TFS 2012 and also TFS 2013 Preview with the integrated SharePoint installation we suffered a long time from the following error when running a search on the project portal (SharePoint):

Your search cannot be completed because no Search service is available. Contact your administrator for more information.

We tried plenty of things but never got it working.

1

Just discovered the following blog post which explains how to fix it:
WSS Search: Your search cannot be completed because this site is not assigned to an indexer

Copied from there:

  1. Go to Central Admin as login as the farm Administrator

  2. Go to Application Management tab

  3. Select SharePoint Web Application Management heading | Content databases

  4. Ensure your web application is the one selected

  5. Select your content database name

  6. Under Search Server – select your server (if your search server drop down is disabled please follow the additional steps below)

  7. Go to 12 hive folder and open stsadm.exe utility

  8. Run the following command psconfig.exe -cmd services -install

  9. Then run stsadm -o spsearch -action start (specify the farm account if required)

This process will register the search services within the SharePoint (WSS) farm and search service will now appear under central administration. Now you can click the service service and create a indexing schedule. After indexing job is completed for the given web application you will notice that search results appear as expected.

Step 7 means "Go to your SharePoint installation folder and open stsadm.exe".

Running these two commands and then running the indexer finally fixed this problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.