I created a new global AD Security Group and tried to add it to my Farm Admins group in Central Admin. It worked no problem. When I try to add it to a site in any other group outside of Central Admin, the people picker cannot find the new group. I can find other existing groups, but when I make a new one, even if its properties match the existing ones, it cannot be found.

What gives?

  • Are you creating that group in the same OU as other groups that are present? Do you have any exclusion filters configured on the User Profile Sync? – Jesus Shelby Jun 29 '13 at 3:21

I had a similar problem when I was accessing a site using a non fully qualified domain name. I.e. The site had been setup with


. Whenever I accessed the site using


the site would function correctly apart from the people picker. If this is the case make sure you have an alternate access mapping in place for both scenarios.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.