1

Situation: New SP 2013 farm with public facing site and InfoPath 2013 form configured to submit to a form library on a SP 2010 farm. When submitting, I get an error:

Cannot find site lookup info for request Uri <the uri for the sp2010 site>

I can connect to the 2010 site from the 2013 server, of course, but the form won't submit. The form is centrally managed with full trust.

Is this something where I'm going to need the form and the target site to be in the same farm?

1

my guess is you wont be able to do this across versions ( not 100% sure on that ). you could change your submit type to use the list web service of the 2nd farm, that should work (depending on authentication configuration - read more below).

Updated

I think if you looked at Fiddler you will see authentication errors, I didn't think about it initially, When saving directly to SharePoint Library in 2010, you are probably passing a claim from 2013 to 2010 (which I am going to assume is NTLM). Even if 2010 was configured with Claims you may have issues because it is not going to trust claims from a 2013 farm unless you explicitly configure it to do so.

With web services, you need to call the service with the domain credentials that have access. WCF is not Claims aware so it wont know what to do with the identity it is presented. You can try and utilize a "web service proxy" to get this to work with InfoPath. I'm not entirely sure it will work with the 2010 web services.

  1. Create a specific data connection file created from InfoPath
  2. Enable data connection authentication for the form.

In both cases you need to have the Secure Store Service running and create a target application that uses windows credentials that can access the 2010 farm.

This enables InfoPath to use credentials stored in a connection file.

Set-SPInfoPathFormsService -AllowUdcAuthenticationForDataConnections $true

In your InfoPath form, you can create a connection to your web service and then save it as a connection file. You will have to open the file and modify the XML directly:

useFormsServiceProxy = True
<udc:Authentication><udc:SSO AppId="" CredentialType=""/></udc:Authentication>

AppId will be your SSS Target Application ID. You will need to upload the connection file to your connection library and reference it from InfoPath.

Full disclosure is that I don't spend a lot of time with Web Services. Here are some Microsoft References you may want to review.

http://technet.microsoft.com/en-us/library/ff621101(v=office.14).aspx

http://blogs.msdn.com/b/infopath/archive/2006/10/30/the-anatomy-of-a-udc-file.aspx

4
  • well I'm not having much luck so far. I even removed the submit connection to a data connection file and I'm still getting an error. Same error actually, only regarding the web service instead of the library itself. – Matt Jun 27 '13 at 14:59
  • You may want to run a trace, with something like Fiddler when you are in the form and see what response you are getting back from the server. It is looking like the server may not be accepting the request. Using Fiddler you should be able to see if it is an authentication problem when the form tries to connect. – Jesus Shelby Jun 27 '13 at 16:39
  • Lists.asmx CheckInFile service is not doing so hot - tells me the same error message, essentially. – Matt Jun 28 '13 at 20:59
  • Hey thanks for the update, I did not get an email about it, apparently. I'll have to give this a try at a later date, because for now we managed to just put the destination on the same SP 2013 farm. Could become relevant again depending on the circumstances – Matt Jul 12 '13 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.