3

I have set up a SharePoint 2013 environment and am using Azure ACS to authenticate users via Google.

This is working really well, however in the top right corner where my user is logged in, it's displaying their name as "https://www.google.com/accounts/o8/id?id=aaaaaaaaaanaaaan".

I would prefer to have their User ID displayed as "something@gmail.com".

Is there a quick way I can change this, for all users and new users, via PowerShell?

My technical skills are very limited on SahrePoint 2013, so if anyone can help with a quick PowerShell script, that would really, really be appreciated.

Cheers!

Rob

1

Not sure if this helps in your situation but take a look at this site..

  1. Open the SharePoint 2010 server that hosts Central Admin

  2. Click Start

  3. Click All Programs

  4. Click SharePoint 2010 Products

  5. Click SharePoint 2010 Management Shell (run as administrator)

  6. Type Set-SPUser -Identity 'Domain\UserName' -Web http://''' -SyncFromAD

  7. Hit Enter (the script will run and once complete will prompt you that it completed)

http://voices.yahoo.com/sharepoint-2010-user-name-displaying-incorrectly-in-11642032.html

  • where i put ''' that's where you sharepoint server name goes. – Joseph D Surgeon Jun 25 '13 at 14:28
  • 1
    Hi Joseph, thanks for the reply. The issue I have is that I'm not synching from AD, I'm getting my claims from Google and Azure ACS. The claim is sending back the users e-mail address, I just need that to be displayed in the user name field and also the User ID for audit reports. – Rob Sked Jun 25 '13 at 14:42
  • I think you would modify the script to do a sync with your provider... I would look further into that step 6 because you need to specify to SharePoint how to show the identity – Joseph D Surgeon Jun 25 '13 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.