Using Sharepoint MOSS 2007, there are a couple of pages/sub sites that need to be hidden. When going into change the navigation, I set the page/sub site to be hidden and save. when I go back to have a look to see if in fact the page/sub site has been hidden or not, it hasn't.

Don't know whether this could be to do with the pages/subsites having already been moved? The pages/sub sites don't seem to want to be hidden from the part of the navigation where they're not needed.


Go to Site Actions--> Site Settings--> Navigation and deselect Show subsites and Show pages. The opposite of what is shown in the image here:

Show or hide Subsite and pages

Following this procedure means that they are hidden in Navigation. They will not be hidden from All Site Content.

Show or hide individual subsites and pages

  1. Do one of the following:
    • On the Site Actions menu, click Site Settings.
    • On the Site Actions menu, point to Site Settings, and then click Modify All Site Settings.
  2. In the Look and Feel column, click Navigation.

    • NOTE The Navigation command appears under Look and Feel only if the publishing features are enabled for your site and you have the Full Control or Design permission level.
  3. In the Navigation Editing and Sorting section, select the subsite or page you want and do one of the following:

    • If you want to show a page or subsite that is hidden, select the item, and then click Show.
    • If you want to hide a page or subsite that is currently visible, select the item, and then click Hide.
  • Wouldn't this affect all of them though? There are only 2 specific ones that need hiding, but there are other sub-sites/pages within the same area that don't need to be hidden. – Casey Jun 27 '13 at 8:29
  • @Casey Sorry, I missunderstood your question. I've added a section on how to hide individual subsites/pages. – Benny Skogberg Jun 27 '13 at 9:04
  • We have tried this but unfortunately when doing this, when going back to check that they have actually been hidden, they're still showing. – Casey Jun 27 '13 at 9:22
  • did you find the solution ? – Vikas Sharma Dec 9 '15 at 9:20

Make sure that if you have Publishing enabled, that you're using a Publishing datasource for your menus. If you're mixing and matching datasource types, these settings may not apply correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.