2

I want to deploy a new custom pagelayout, like I did always done it before too. It will be deployed without any errors. It appears on the 12-directory in the correct folder. The feature is availible and activated. But I cannot select it from the new-page-list and it doesn't appear in the masterpage-gallery.

module.xml:

<?xml version="1.0" encoding="utf-8"?>
<Elements Id="8ec1f52c-3eac-49ee-bb5b-7dcc2741f83e" xmlns="http://schemas.microsoft.com/sharepoint/">
  <Module Name="Product Layouts" Url="_catalogs/masterpage" RootWebOnly="True" List="116">
    <File Path="ProductCategory.aspx" Url="ProductCategory.aspx" IgnoreIfAlreadyExists="True" Type="GhostableInLibrary" >
      <Property Name="Title" Value="Product Category Page Layout" />
      <Property Name="ContentType" Value="$Resources:cmscore,contenttype_pagelayout_name;" />
      <Property Name="PublishingAssociatedContentType" Value=";#Product Category Page;#0x010100C568DB52D9D0A14D9B2FDCC96666E9F2007948130EC3DB064584E219954237AF390064DEA0F50FC8C147B0B6EA0636C4A7D40108;#" />
    </File>
  </Module>
</Elements>
5
  • 1
    Did you checked whether your custom pagelayout available in SharePoint Designer?
    – Suren
    Jun 24, 2013 at 7:41
  • No, we don't use SharePoint Designer.
    – Sebastian
    Jun 24, 2013 at 10:26
  • I have now checked your suggestion. The pagelayout is not listet in SP-Designer, either in SP-Manager.
    – Sebastian
    Jun 24, 2013 at 10:45
  • which version of SharePoint you using? You try to create pagelayout using visual studio right? If so where you deployed your solution (site or web). Have you verified in both site features and web features?
    – Suren
    Jun 24, 2013 at 10:52
  • SP-Version is tagged -> 2007. That's right, I deploy a pagelayout with VS. It's a Site feature and active at this scope.
    – Sebastian
    Jun 24, 2013 at 10:56

2 Answers 2

0

I have tried this procedure and created page layout. Please refer this and confirm whether you done everything.

http://pinnacleofindiana.com/blog/developers/2012/03/28/creating-a-sharepoint-2010-page-layout-with-code-behind/

2
  • It's a nice how-to but for SP-2010.
    – Sebastian
    Jun 24, 2013 at 11:19
  • I think sharepoint 2007 follows the same procedure. have you tried?
    – Suren
    Jun 24, 2013 at 11:23
0

Well, in the end it was a permissions problem in the database.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.