0

I have a few fields that I am adding to a list that will be automatically populated and use for tagging against a document for search crawling, e.g. Document Owner. When I set them to be hidden in the document library, save the template and create from the template all the fields get re-set to optional again. Has anybody else seen this issue? I can't seem to find anything about it.

1

I have not tried it this way but I know if you create a content type and set any fields to hidden they do not appear at all in the library the content type is added to.

Try creating a content type with the fields set to optional, apply it to you library and then set the fields in the content type to hidden.

They should now be hidden in your library. If you now save your library as a template and create another from it - it should refer back to the content type and so respect the hidden settings.

  • I'm an absolute egg! You're dead right. I hadn't gone back in to the content type itself so when you re-created from the document library it takes the snapshot from the content type and not the list settings! Bit confusing functionality. Thanks very much!!!! – Dee Jun 25 '13 at 2:42
  • Glad you got sorted :) – Dave Paylor Jun 25 '13 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.