SharePoint 2013 running on Windows Server 2008 R2, updated with the latest CUs (March, April, June, see http://technet.microsoft.com/en-us/sharepoint/jj891062.aspx). All O.S. updates installed.

It's a new server, I installed SharePoint today, applied the CUs and started creating the farm (single server, with the database on a separate machine).

The distributed cache service keeps crashing with these errors:

Log Name: Application
Source: .NET Runtime
Date: 20/06/2013 17:45:32
Event ID: 1026
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Application: DistributedCacheService.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: Microsoft.ApplicationServer.Caching.DataCacheException

Log Name: Application
Source: Application Error
Date: 20/06/2013 17:45:33
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Faulting application name: DistributedCacheService.exe, version: 1.0.4632.0, time stamp: 0x4eafeccf
Faulting module name: KERNELBASE.dll, version: 6.1.7601.18015, time stamp: 0x50b8479b
Exception code: 0xe0434352
Fault offset: 0x0000000000009e5d
Faulting process id: 0x1160
Faulting application start time: 0x01ce6dccc2c8252e
Faulting application path: C:\Program Files\AppFabric 1.1 for Windows Server\DistributedCacheService.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: 70ffbeef-d9c0-11e2-80ea-005056a002c5

Looking around, I found some posts dealing with the same issue, which seems to be caused by missing permissions:


This seems indeed to be my case, as I'm using distinct service accounts with no admin privileges for the application pools.

However, as others have noted in comments to those posts, the WindowsFabricAllowedUsers group just isn't there, so I don't know what to do.

Any ideas?

Update 1

The problem is not related at all to the application pool service account. I destroyed the farm, uninstalled SharePoint from the server, re-installed it and re-created the farm, and upon accessing the Central Administration (without having configured anything yet), the distribute cache service still crashes with the same errors.

Update 2

The problem is not caused by any SharePoint CU; I tried installing only the March CU, and then I tried again using the plain RTM release of SharePoint 2013: same behaviour.

Also, this doesn't help at all.

  • Which version of App Fabric you are using? You can get that info from Control panel - installed updates. Commented Jul 4, 2017 at 19:28

3 Answers 3


If someone found this in 2019, like I did, here is the solution worked for me in SharePoint 2019, it's magic with partitionCount change in cofiguration: Distributed Cache service keeps crashing on start up

This errors with distributed cache are often caused by permission issues. This link helped me, when changed managed account of Distributed Cache service The AppFabric Caching Service service terminated unexpectedly, it says account should have SPDataAccess database role in sharepoint_config database.

  • I've not had to touch SharePoint in a while (which I'm really grateful for), but this at least makes sense. Upvoted and accepted.
    – Massimo
    Commented Jan 1, 2021 at 4:31

So I am coming to the same conclusion as above. I don't have that group either. I think I know how to solve the issue, but I am not able to test it due to permissions at the moment. The account running the service either needs login as a service rights or login as a batch job or both. Hopefully this will help someone. IF I was guessing I would say its login as a batch job. Its an IIS thing.

  • Not an IIS thing. AppFabric Cache is a separate OS feature, with its own permissions and security groups. Installing the feature through scripts or SharePoint runs the risk that the script will leave some details unchecked, like adding all required groups, ensuring the account has all permissions etc. Not like this hasn't happened with SP before. Commented Oct 16, 2014 at 7:24

Try this:

  • Try to reregister .net framework 4 in IIS; go to your .net directory and run Aspnet_regiis.exe with admin privileges.

and/ or

  • Try to setup your machine FQDN in the host server file: find host file inside windows drivers etc directory and set up there your IP with FQDN.
  • 1
    Can you please add details about how to perform the two operations you mention to your post? Commented Mar 4, 2014 at 14:11
  • 1
    AppFabrid is unrelated to the framework version, IIS, or the machine's domain name. Commented Oct 16, 2014 at 7:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.