6

I have an extensive set of pictures on my SP13 enterprise wiki to display division capabilities. The first one I added to a page worked great. Then, I created the second picture library and tried to add that in another section of my page.

The library appears in the dropdown to select when I add the webpart, but the images from the first picture library I created appear in the slideshow.

Can you not have two slideshows rendering two different libraries on the same page?

  • Slideshow = Slides view? Interesting, when I add a webpart and switch it to "Slides" view, it doesn't show anything at all except of the webpart title after I save the page. Even with only one webpart on the page. Both wiki and normal pages... I use O365 SP2013 mode, so it should be the latest version I guess :) – Andrey Markeev Jun 19 '13 at 20:45
  • I am having the same issue. I created a picture library slide show and it works great. I then add another webpart - picture library slide show, point it to another image library, but the images from the first slide show show up. I took a look at the article that was listed, but it only deals with image size. Did the original poster get this to work? Thanks! – user32630 Aug 19 '14 at 21:05
1

This has been a topic on the technet boards. Take a look at this article. It has a couple of answers, though I don't like either. It appears to be a sizing issue with the underlying style sheets in SharePoint.

http://social.technet.microsoft.com/Forums/sharepoint/en-US/5ca65f7f-770b-4b0f-8e40-d08578a6442b/sharepoint-2013-picture-library-slideshow-web-part-image-not-displaying-correct-size

Hope this helps.

0

I have a work around for this, its a bit messy but it does work

Lets say you have 2 Picture Libraries in the same site called Photo1 and Photo2

You wish to display them on a page called MyPhotos.aspx

The process is as follows:

  1. Create a file called HideEverything.css this contains styles to hide all the unwanted elements on a page, basically everything except the Slide Show. Upload this to a regular library.
  2. Create a web part page called P1.aspx insert the Slideshow Web Part and connect it to Photo1. Add a content editor web part below this and Link it to HideEverything.css
  3. Create a web part page called P2.aspx insert the Slideshow Web Part and connect it to Photo2. Add a content editor web part below this and Link it to HideEverything.css
  4. Create a WIKI page called MyPhotos.aspx set the layout too two columns. In the left column insert a page viewer web part and set it to display P1.aspx?IsDlg=2, in the right column insert a page viewer web part and set it to display P2.aspx?IsDlg=2

Your slideshows will now display the correct content on MyPhotos.aspx

I have the styles for hiding the page elements if you need them

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.