0

I have looked around on Google, and I have found tutorials on how to initiate a workflow from a custom action in the ribbon, but I have run into a problem. I am not sure why (I assume I have a setting wrong that isn't mentioned in the tutorials) but the drop-down under 'Initiate Workflow' in the Custom Action creation dialog contains no workflows at all. I have tried creating test workflows of both site and reusable types. I have several existing workflows that are associated with this list, and I have tried creating test list-associated workflows as well. Does anyone know why I wouldn't be able to see my workflows here?

EDIT: I have no idea what the problem was, but I used the URL location of the initiation form, and now the 'Initiate Workflow' drop-down shows my workflows. Guess it fixed itself...

  • Are your worflows associated with the list or just with the content types in the list. This could be a possible reason why you don't see any workflows. – Stefan Bauer Oct 4 '14 at 21:14
0

Under the list ribbon

New Quick Step

  • Launch Application
  • start an existing workflow
  • add label and image
  • press Okay

This should now add a button to your Item ribbon

Activation requires selection of a List Item first

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.