0

I have an intranet site (non-SharePoint) that is located at a site like http://www.oldportal.example.com. The site is hosted on an Apache server and is only accessible on the network. The site uses no authentication method.

I also have a SharePoint 2010 Foundation farm on the same network located at https://newportal.example.com. This environment also has Search Server Express.

I created a content source that includes http://www.oldportal.example.com/index.php with "Only crawl within the server of each start address" selected in crawl settings. I also created an include crawl rule for http://.oldportal.example.com/

Until all the content and solutions on http://www.oldportal.example.com can be migrated to https://newportal.example.com it is neccessary that the content source spider the old site.

When the crawl completes I see an "Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled." error. Am I messing up some configuration setting here, or is there an access problem I am not seeing?

Side note - this crawl has worked before, albeit in a limited capacity.

1

It seems that the account used for Content Crawling does not have access to the actual source of data. Practically this could also mean that you have an locked account, or password has changed, or maybe on the Content Source that particular account has no access anymore.

Use the SP-CA, and via Manage Service account check which account is used by the Content crawl. Make sure that account still has a valid password, and permissions on the source.

0

C. Marius definitely had some valid points, but none directly applied to this situation The issue was resolved through Crawl Rules, not changing permissions on the site. When the crawl service went to the PHP site it was passing the content crawler service account credentials. Because of the authentication type the PHP site used, the passed credentials did not work.

I changed the "Specifiy Authentication" section of the crawl rule to "Specify a different content access account," entered the same credentials as the default crawl service account and cleared the "Do not use basic authentication" checkbox. This allowed the external site to be crawled successfully.

While this could be unqiue to this network, I have read other forums where people have had similiar issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.