0

I am having a strange problem with UserProfileService that I can't seem to resolve. When I add http://<mySite>/_vti_bin/UserProfileService.asmx as a data source, none of the methods are listed, and when I click Finish I get the error The file is not a valid XML file. The form contains XML that cannot be parsed: End tag 'ul' does not match the start tag 'p'. From looking at the source that comes up when I open this page in a browser, it seems that the problem may be that there are a large number of <p> tags without closing </p> tags. I also tried appending ?wsdl to the URL, but then I get the message The selected XML document cannot be used as a data connection because it includes inline XDR schemas. Has anyone else had this problem?

EDIT: Just for clarification, these errors both come up when I try to create the data source, preventing me from actually creating it.

| improve this question | | | | |
1

I would be incredibly surprised if the SharePoint user profile service was returning malformed XML -- unless it was modified or you don't have permission to access it and it's trying to serve you some other data...

Make sure the URL you're entering in InfoPath is: /_vti_bin/UserProfileService.asmx?WSDL

Also try logging on to the SharePoint site you're attempting to get UserProfileService data from right before you try accessing the service in InfoPath. Oh! And make sure you're using https:// if your site is also running on https..

Additionally, you might find it easier to simply use the 'User Information List' from the site you're working with, just set the q:User_name field to the userName() function when you load the form then query the data from the list... just as simple and won't need to change when they stop providing asmx and other services in _vti_bin :-)

| improve this answer | | | | |
0

Here's a link to a blog post about using the UserGroup web service, it might help you with the UserProfile service:

http://blog.ianchivers.com/2011/01/using-sharepoint-usergroup-web-service.html

| improve this answer | | | | |
  • This won't work in my case because the XSD files are not created until the data source has been created, and as I can't create the data source, I can't modify the XSD files. – Crash Jun 11 '13 at 13:16
  • Are you getting a permission problem ? Instead of XML being returned for the WSDL request you are getting a logon html page ? – Ian Jun 11 '13 at 13:24
  • When I enter it in a browser, I am getting XML. It looks valid to me, but I only just glanced at it. – Crash Jun 11 '13 at 13:27
0

This is an old post, but I don't see a resolution provided, so I'll share a solution that fix this issue for us. We were getting the same error as the above user,

but were instructed by MS to Disable the loopback check on the server and this issue went away.

Hope this helps someone else.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.