2

I created a custom page layout with SharePoint Designer for use as a new default or welcome page in a publishing site. The page layout should contain a summary link web part that is pre configured with a list of links. SharePoint Designer already has some sample links included in the webpart and I modified them as needed. The preview also in SharePoint Designer shows just what I need. But when I create a new page, using my custom page layout, in my SharePoint site, it has the summary link web part but empty without the links.

<PublishingWebControls:SummaryLinkWebPart runat="server" Description="Externe Datenquellen" 
ListDisplayName="" HelpLink="" AllowRemove="True" IsVisible="True" AllowHide="True" UseSQLDataSourcePaging="True" SummaryLinkStore="" 
ExportControlledProperties="True" DataSourceID="" Title="Externe Datenquellen" ViewFlag="0" NoDefaultStyle="" AllowConnect="True" FrameState="Normal" 
PageSize="-1" AsyncRefresh="False" ExportMode="All" PartOrder="2" DetailLink="" ShowWithSampleData="False" ListId="00000000-0000-0000-0000-000000000000" 
FrameType="TitleBarOnly" PartImageSmall="" PartImageLarge="" IsIncluded="True" SuppressWebPartChrome="False" AllowEdit="True" ManualRefresh="False" ChromeType="TitleOnly" 
AutoRefresh="False" AutoRefreshInterval="60" AllowMinimize="True" ViewContentTypeId="" Dir="Default" InitialAsyncDataFetch="False" MissingAssembly="Cannot import this Web Part." 
HelpMode="Modeless" ListUrl="" ID="g_9ff5513e_80b2_4c71_92c3_49c7db485df8" ConnectionID="00000000-0000-0000-0000-000000000000" AllowZoneChange="True" IsIncludedFilter="" 
ZoneID="" __MarkupType="vsattributemarkup" __WebPartId="{9ff5513e-80b2-4c71-92c3-49c7db485df8}" WebPart="true" Height="" Width="">
<DataFields>
</DataFields>
<SampleData>
<dsQueryResponse>
                    <Rows>
                        <Row Title="Item1" LinkUrl="http://Item1"  Order="2" BeginColumn="False" IsGroupHeader="False" />
                        <Row Title="Item2" LinkUrl="http://Item2"  Order="3" BeginColumn="False" IsGroupHeader="False" />
                        <Row Title="Item3" LinkUrl="http://Item3"  Order="4" BeginColumn="False" IsGroupHeader="False" />
                        <Row Title="Item4" LinkUrl="http://Item2"  Order="3" BeginColumn="False" IsGroupHeader="False" />
                        <Row Title="Item5" LinkUrl="http://Item2"  Order="3" BeginColumn="False" IsGroupHeader="False" />
                        <Row Title="Item6" LinkUrl="http://Item2"  Order="3" BeginColumn="False" IsGroupHeader="False" />
                    </Rows>
                    </dsQueryResponse>
                  </SampleData>
<Xsl>
    <xsl:stylesheet xmlns:x="http://www.w3.org/2001/XMLSchema" version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform" 
    xmlns:cmswrt="http://schemas.microsoft.com/WebPart/v3/Publishing/runtime" exclude-result-prefixes="xsl cmswrt x" > 
        <xsl:import href="/Style Library/XSL Style Sheets/Header.xsl" /> 
        <xsl:import href="/Style Library/XSL Style Sheets/ItemStyle.xsl" /> 
        <xsl:import href="/Style Library/XSL Style Sheets/SummaryLinkMain.xsl" /> 
    </xsl:stylesheet>
</Xsl>

0

You would need to use the SummaryLinkStore property of the webpart to store the preconfigured data.

  • 2
    Can you please extend this answer with some information about how to use that property, it will make your answer more helpful :) – Robert Lindgren Sep 24 '13 at 6:19
0

This is an old question but I'd like to share something because I experienced same issue and spent some time to figure out the issue. What I noticed is, the summary links become visible only after checking in a page. I am not sure why it is.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.