0

I'm trying to create a list workflow in SharePoint designer 2013. When I click on the OK button it gives me the error.

Server Side activities have been updated. You need to restart SharePoint Designer to use the updated version of activities.

I have restarted spd, and my computer. Is there anyone else who has run into this issue? Thanks

  • you should uninstall workflow manager client 1.0. – user43249 Jun 13 '15 at 15:54
  • Is this a dead thread? I have the same problem, and have found no solutions anywhere yet. And in line with Bob Elander above, I find the problem is with SP2013 workflows. I do not have workflow manager installed. I've uninstalled and re-installed SPD many times, cleared cache, etc. I've tried everything and I have yet to see any solution to this problem... – Nicodemus88 Jun 27 '17 at 12:43
  • When you create a new workflow choose "SharePoint 2010 Workflow" in "Platform Type" – Jean Leles Sep 18 '17 at 17:53
2

Try uninstalling SPDesigner and then removing the following folders.

C:\Users\username\AppData\Roaming\Microsoft\SharePoint Designer

Reboot and then re-install with the latest version.

This cured it for me, seems to have issues with roaming profiles from time to time.

0

I have the same issue, when I have SPD 2013 x64 installed on my server. I have installed SPD 2013 x32 on a different machine, and I was able to create 2014 workflows. I am not sure if moving to a different machine or using another version (32bit vs 64bits) version solved the problem.

I hope this helps...

0

Copy Microsoft.SharePoint.WorkflowServices.Activities.Proxy.dll assembly to WebsiteCache folder (%USERPROFILE%\AppData\Local\Microsoft\WebsiteCache{Site Name}\15.0.0.4745)

http://www.jrjlee.com/2014/10/server-side-activities-have-been-updated.html

0

Please

can you upload the file Microsoft.SharePoint.WorkflowServices.Activities.Proxy.dll to resolve this problem

  • 1
    This does not answer the question as per the StackExchange standards. Please check How to Answer. One-liners qualify for comments. – Yash Saraiya Feb 23 '16 at 10:30
0

May be I am late to answer here, but I was facing same problem and i found exact solution, the actual culprit is Workflow client installed with Visual studio. Just uninstall it from Program and Features in control panel

0

I have suffered the same fate with SPD 2013 and SharePoint online. None of the suggestions above have worked but when I choose Platform Type: SharePoint 2010 it works fine. Does not for Platform Type: SharePoint 2013.

0

How to install the SharePoint Designer 2013 latest version.

  1. Clearing the cache

    Removed contents from

    C:\Users\\AppData\Roaming\Microsoft\SharePoint Designer\ProxyAssemblyCache C:\Users\\AppData\Local\Microsoft\WebsiteCache C:\Users\\AppData\Roaming\Microsoft\Web Server Extensions\Cache

    Unchecked "Cache site data across SharePoint Designer sessions" in SPD Application Options

    1. Try uninstalling SPDesigner and then removing the following folders.

      C:\Users\\AppData\Roaming\Microsoft\SharePoint Designer

      • Reboot and then re-install with the latest version in below order.

      Order of installation 1. SharePoint Designer 64-bit (sharepointdesigner2013_64bit.exe) File Version: 15.0.4420.1017

      SharePoint Designer Service Pack 1 (spdsp2013-kb2817441-fullfile-x64-en-us.exe) File Version: 15.0.4569.1506

      Security Update for Microsoft SharePoint Designer 2013 (spd2013-kb2863836-fullfile-x64-glb.exe ) File Version: 15.0.4615.1001

      Update for Microsoft SharePoint Designer 2013 ( spd2013-kb3114337-fullfile-x64-glb.exe) File Version: 15.0.4787.1000

      Update for Microsoft SharePoint Designer 2013 (spd2013-kb3114721-fullfile-x64-glb.exe) File Version: 15.0.4849.1000

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.