I've got my SharePoint Foundation 2013 to work with WAC ... Test-Environment via http works fine.

Switching to https fails due to problems with my ssl-cert !?

I've disabled the wac-server via


After that I created a new via

New-OfficeWebAppsFarm -InternalURL https://srvwebapp -ExternalUrl https://webapp.mydomain.tld -CertificateName webapp.mydomain.tld -EditingEnabled

After that a look in the events shows up warnings about SSL/TLS

Could not establish trust relationship for the SSL/TLS secure channel.
The remote certificate is invalid according to the validation procedure.

Events by OfficeWebAppsMonitoring are 1206, 1010, 1046, 1156

I have no idea whats wrong ...

The SSL-Cert is from an official center. I've imported root-cert and intermediate-cert via mmc-snapin for local computer and finished the csr in iis with the server-cert.

https://webapp.mydomain.tld/hosting/discovery opens fine and I was also able to connect the Sharepoint via

New-SPWOPIBinding -ServerName webapp.mydomain.tld

and changed WOPI-zone from external-http to external-https via

Set-SPWOPIZone external-https

But due to the SSL/TLS-error I'm not able to use WAC

Any ideas what I've missing?


Based on the Configuration everything looks perfect but you can try below steps.

  1. Add WAC Certificate to Trusted Root Authority under local Machine account on all SharePoint Servers.

  2. Import WAC Certificate in SharePoint.

    1. In SharePoint Central Administration, in the menu on the left, click Security and then, under General Security, click Manage trust.

    2. On the Trust Relationships page, in the menu at the top of the page, click New.

    3. In the Establish Trust Relationship window, in the General Setting section, in the Name box, type the name that you want to give the SSL Certificate.

    4. In the Root Certificate for the trust relationship section, click Browse to browse for and select the root certificate (i.e. WAC.crt).

    5. In the Establish Trust Relationship window, click OK.

    6. If the certificate is installed successfully, it should be listed on the Trust Relationships page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.