I have a State machine Workflow that consumes a WCF Service in https (Basic Authentication, security mode transport). It works fine in our test environment, but it had problem in the integration server:

  • First call in the integration server takes more than 2 minutes to open the connection with the WCF. In my test environment, it works instantly.

    Then, the following calls to the WCF are just fine. Only the first call to open the connection (as long as the connection is not closed, so within the receiveTimeout range.)

  • If it consume the service in http without credential, it will always work.

So we are not sure where the problem may come from... It's not the WCF... We tried other authentication method in https too such as custom authentication with UserNamePasswordValidator, but same problem.

We tried to consume the service in the integration server from a windows application (outside SharePoint), and the first call was also instantly...

The only problem comes from the workflow. The services binding and workflow are identical both from the test environment and integration server.

HTTP would be ok because it's in our internal network but we need at least a small authentication part so not everybody from the network may consume it...

Can anyone know a way to fix this problem?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.