1

SharePoint 2010. We have an infopath form that's basically a trouble ticket. Several (but not all) of the fields are promoted, and appear in the main/default view as columns. These columns can be sorted, and views can be created using filter/sort/group on these columns.

However, when trying to use the Metadata Navigation, the Infopath columns are "grayed out" and can't be added to either the "navigation hierarchies" nor the "Key Filters" lists, and thus there is no metadata navigation available in the library view.

I've searched Technet and MSDN, as well as SE/SO and consulted our SharePoint tech support team, but I haven't found out why Infopath promoted fields are not treated as "normal" columns.

Any suggestions on where to look, or what to try, are welcome.

1

The Metadata Navigation feature uses indexes to provide fast responses. These indexes are automatically created when you configure it. These fields might be blocked by the InfoPath deployment process. Have you tried manually indexing them first? Have you deployed the form as a content type or straight to the library?

  • The form is deployed straight to the library. I'll look into forcing the indexing. Thanks for the tip. – TechWriter James Jun 17 '13 at 13:11
0

It seems that it is simply not supported by design. Sad but true.

http://www.sharepointanalysthq.com/2011/06/managed-metadata-column-limitations/

  • 1
    That link was interesting reading, and I'm glad you revealed it to me, as I'm also working with a lot of Managed Metadata provisioning and training users. However, the question remains open, as I'm asking about Metadata Navigation (which is distinct from Managed Metadata). The Infopath forms in question are not using Managed Metadata; their columns are non-managed, including some "Selectable" and some "Open field" options. – TechWriter James Jun 14 '13 at 12:40
  • I've run into the same horrible limitation. Unless I use InfoPath custom dropdown lists (hard coding in their values individually and then recompile/publishing the form) I can't 'see' the lookup fields I've created based on other resource lists, in the Available Hierarchy fields in "Metadata Navigation" settings. Yes this is NOT related to Term Store - I did know that limitation. – April Drake Jul 3 '13 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.