1

When I am trying to edit a document set, the Edit Properties form only shows the Name field and no other properites from the document set. View Properties shows all the properties of the document set just fine, I've checked and the columns are set to Optional, so these should show up in the Edit Properties form. When I create a document set, all the properties show up. There have been no customizations to the default edit form. What am I missing, why are the properties of the document set not showing up on the Edit Properties form?

  • Ever find the answer? Have same problem with standard list and custom content type. – user21905 Jan 11 '14 at 17:46
2

As a service to anyone who has ever experienced this bizarre problem, here is an obscure solution that worked for me:

http://sharepoint-community.net/profiles/blogs/document-sets-the-case-of-the-disappearing-properties

Depending on the circumstances it may be relevant, particularly if you've ever edited the form page.

Edited on request: ----%<---- When you add a list web part to a document library display or edit form, it adds a line of code to the dispform.aspx or editform.aspx.

<TemplateName xmlns="http://schemas.microsoft.com/WebPart/v2/ListForm">DocumentLibraryForm</TemplateName>

After commenting out the line (on both the dispform and the editform), everything was back to normal and the users could see and edit all of the properties.

This seems to occur only on document library forms as my list forms with added web parts were not effected. ----%<----

In my case, I had added a list view web part showing the document set contents to a form in another list. Sure enough, the line was added to the two forms and removing it solved the problem.

  • 1
    flayman, please add the important part of the posts in your answer as link only answers are subject to void when the link is broken. – Arsalan Adam Khatri Jan 14 '15 at 14:05
  • 2
    Very well. Quoted from linked article with main nugget of information. – flayman Apr 13 '15 at 10:49
  • Amazing. This is quite often problem in Document Set and you have found the solution. Thanks. – ECM4D Jun 27 '15 at 21:37
  • I wish I could take credit, but credit goes entirely to the author Bill Burke. I just happened to find it. – flayman Feb 9 '16 at 10:46
-1

Where are you looking? To get to the detailed settings you need to go into List Settings and then click on the Document Set in the content types. From there you should be able to get to your settings.

  • Yes, I was looking at library settings, and then I clicked on the document set content type, and all my columns are set to Optional, which I understand should be visible on the Edit Properties form. I also went into the Document Set Settings, and there is nothing there that helps. Just to clarify, I'm refering to properties at the document set level, not document level. – Roy Varghese Jun 4 '13 at 19:06
  • The last option in the Document Set Settings page allows you to choose the view that will be used inside your Document Set. – Dave Paylor Jun 4 '13 at 20:42
  • I believe there is a misunderstanding. I'm having issues with the editing document set fields/columns. Any time I try to edit document set fields/columns, I only see the name field/column, but I have several other fields/columns that should be visible when editing. They are visible when viewing and adding a new document set, but when editing the document set only the name field/column is viewable. – Roy Varghese Jun 5 '13 at 1:14
  • Eeek - you are right. I am trying to answer a question you have not asked - so sorry! – Dave Paylor Jun 5 '13 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.