-1

I have created main Enterprise Wiki site collection and I have enabled the “Metadata Navigation and Filtering”. Then I have created a subsite also based on the enterprise Wiki. and I have defined that the metadata Navigation will be based on a predefined term set. Same as the steps mentioned in this link but the only difference is that I am using SharePoint 2013 and not 2010:-

http://www.jasperoosterveld.com/2011/09/creating-knowledge-centre-with_07.html

Then when I navigate back to the sub site the term store showed up in the left side of the page, but after navigating through the term set it disappeared and I cannot re-showed it again?? Any idea what might cause this behavior?

BR

-:::EDITED:::-

After working on it I did the following:-

  1. I modify the EnterpriseWiki.aspx page using SP designer , then i added the following at the beginning of the page:-

    <%@ Register TagPrefix="wssuc" TagName="MetadataNavTree" src="~/_controltemplates/MetadataNavTree.ascx" %>

  2. and put this code in the end of page’s code.

    <asp:Content id="Content1" runat="server" contentplaceholderid="PlaceHolderLeftActions"> <wssuc:MetadataNavTree id="mdnt" runat="server" /> </asp:Content>

  3. but the problem now is that the navigation tree showed up, but currently if i click on a term it will always redirect to the home page , instead of displaying the wiki articles under this term as shown below:-

enter image description here

  1. the second problem is that the term tree will be shown to site collection administrator only . the readers and contributors will not be able to see the term tree !!!!.
  • thanks @Robert for the edit, but did this issue ever happen with u ? – john Gu May 28 '13 at 14:16
1

Why is it your sub-site is using navigation other than parent navigation (I assume your parent site is already using managed navigation, right)?

BTW, your parent and child can definitely use managed navigation connected to different term sets. In such case, you need to define the Term driven pages for such term sets in Term store management.

enter image description here

  • thanks for the reply,,, this problem drived me crazy!!!. now in my case i do not want the parent site to have any metadata navigation, but for each subsite i have defined a metadata navigation based on term sets (each subsite is linked to a different term set). but the problem is that nothing is being displayed on the left side of the page (currently i have ONLY the "about this wiki" && "site contents" links) instead of having the term set hierarchy displayed. – john Gu May 28 '13 at 8:46
  • after further investigation i found that this is a common problem as mentioned in this link:- markuspersson.wordpress.com/2012/01/19/…. but i am not sure how i can apply the navigation refernece ? – John Peter May 28 '13 at 9:21
  • 1
    Can you double check if you enable those term sets to be used for navigation in the term store management tool -> Intended use – Falak Mahmood May 28 '13 at 9:44
  • thanks for thr reply, yes I have enable them to be used for navigation – john Gu May 28 '13 at 10:06
  • can you check my Edited answer – john Gu May 28 '13 at 12:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.