0

I am new to SharePoint 2013. I have developed an app using vs 2012. When I try to deploy the app, then I am getting the below error.

Error : Sorry, apps are turned off. If you know who runs the server, tell them to enable apps.

I have google it and find the below link:

http://technet.microsoft.com/en-in/library/fp161236.aspx

In this link, they are saying that Click Start, point to Administrative Tools, and then click DNS.

But I have not find DNS or DNS Manager.

Can any one help me.

2

Without knowing more information about your environment, then it is hard to give you exact advice. You should not just go in and start making changes to DNS unless you are authorized to do so within your company's environment. And since you do not know how to install/find the DNS MMC snap-in, I am going to bet that is probably not something you have ever done before.

You should put in a ticket with your helpdesk along with a link to the TechNet article that describes how and why this configuration is important. If you are in fact supposed to manage DNS yourself, and you don't know how, that is not a question that can really be answered here. It's too complex and depends a lot on how your environment is set up.

Here are the steps at a high level (I know you have already seen them, I am just adding them for completeness).

Assuming your SharePoint is accessed via portal.domain.com

  1. Configure the wildcard record *.apps.domain.com as a CNAME record pointing to portal.domain.com.
  2. Create a "star" or "wild-card" SSL certificate for your server.
  3. Configure the Subscription Settings service app on your server using PowerShell
  4. Configure the App Management service app using PowerShell
  5. Configure the URL settings for the app domain in Central Admin apps as the prefix and domain.com as the domain.
| improve this answer | |
0

try this well documented example

| improve this answer | |
  • 1
    Please extend this answer, it is no guarantee that the link will always work. It would be awesome if your answer at least pointed in the correct directions :) – Robert Lindgren May 27 '13 at 19:32