0

I'm having this problem where I'm creating a document set, and the New Document button is greyed out. I've searched the internet for answers, and I've tried them all:

  • Activating Client Integration -> was already activated, deactivating and reactivating didn't solve the problem.

  • Enabling content type management -> was already enabled, disabling and reenabling didn't solve.

  • Disabling UAC -> Major WTF of a solution. Tried anyway, didn't work.

  • Adding and removing different content types to the library. Didn't work. I even set it to accept all content types. Still didn't work.

  • I've also checked for any code that might be forcing the button to be disabled. There is none.

BTW I'm an admin and my permissions are set for full control.

1 Answer 1

1

Try clearing the web application blob cache with powershell

More details here: http://www.sharepointdiscussion.com/forum/yaf_postst504_UserAgent-not-available--file-operations-may-not-be-optimized-SharePoint-2013-error.aspx

4
  • I do not find anything on that link explaining why this could help getting the New Document icon to be enabled. Can you please explain? :) May 30, 2013 at 11:08
  • i checked ULS and found this error: "UserAgent not available, file operations may not be optimized" whenever I'm opening the docset so I tried that and worked. May 30, 2013 at 11:33
  • 1
    Oh in addition - if you're also using custom masterpage, it might be conflicting with the docsethomepage.aspx when opening the docset May 30, 2013 at 11:35
  • The answer was your last comment. After a lot of javascript debugging I found out that the site style is removing a tag that Sharepoint is looking for. Thanks!
    – Geeky Guy
    Jun 25, 2013 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.