1

I have two users group Contributor & Reader. And I have the following hierarchy:-

Site Collection (containing both Contributor & Reader )

-Subsite A (containing both Contributor & Reader )

-Subsite B (containing both Contributor & Reader )

-Subsite C (only admin, Contribur and reader are not allowed to see this sub site)

The problem I am facing is as follow:-

  1. If the admin want to search for the word “test” then all the pages will be retrieved correctly.
  2. If any user inside the contributor or reader groups search for the word ”test”, then no result will be returned. although both of them can see pages containing the word “test”. And I have manually crawl all the web application content before trying the search.

So what is causing this?, and do I have to give the users read permission on Subsite C ,, for the search to work ?.

2
  • 1
    Are the files checked in and approved? May 24 '13 at 15:02
  • YES THEY ARE...
    – John Peter
    May 24 '13 at 16:02
1

Have you broken permission inheritance anywhere in the site collection?

When permission inheritance is stopped anywhere within site collection, then ASPX pages (and its content) in that site collection will not be indexed by default.

This is a security feature implemented to prevent users from using the search to view information where they don't have the correct permissions for.

To disable this behavior, go to Site Settings > Search and Offline Availability > Indexing ASPX Page Content

Video Source: http://technet.microsoft.com/en-us/video/tdbe12-role-based-management-in-sharepoint.aspx (Start at: 11:20 - End at: 16:07)

2
  • but at the end the reader group users are able to see pages containing the search criteria words as i mentioned abpve. so in this case they have permission to view these pages and these pages should be returned in the search. Secondly i do not think there is any index problem since the search will work well if the site collection admin is using it ..
    – John Peter
    May 24 '13 at 14:36
  • Hi John, did disabling the behavior solve your question?
    – TempaC
    May 27 '13 at 8:05
1

Check under WebApplication permission that your crawl account has Read Access.

In Central Admin:

Application Management --> Manage web applications --> Click the line of the web app --> In Ribbon "User Policy"

Make sure that the Search Crawling account is added as Full Read

5
  • yes the sps_farm username has a full read permission
    – John Peter
    May 24 '13 at 14:29
  • 2
    And sps_farm is your "Default content access account"? May 24 '13 at 14:35
  • i am not sure,,, how i can check this please ...
    – John Peter
    May 24 '13 at 14:39
  • 2
    Go to Manage Service Applications --> Search Service Application. In the middle "System Status" you will se "Default Content access account" May 24 '13 at 14:40
  • yes it is also SPS_Farm
    – John Peter
    May 24 '13 at 14:41
0

This just happened to me recently. Depending on the total items in the list or document library, you will have to WAIT for some hours. In my case, i have 62942 document in my document library, my user had to wait for like 12 hours for the page to properly re-index for the user. This usually happen when you just add the user to the list or document library. I hope this helps?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.