0

I am having an issue in one SharePoint site. We have recently migrated from 2007 to 2010.

Problem: Not able to browse the website first time (After opening the browser). It needs 3-4 refreshes and then it will prompt for credentials to browse. This is intermittent.

we have checked DNS entries and everything is right.

Error in SP Logs: Alternate access mappings have not been configured.  Users or services are accessing the site http://servername with the URL http://aa.  This may cause incorrect links to be stored or returned to users.  If this is expected, add the URL http://aa as an AAM response URL.

AAM settings:
Internal URL              Public URL                Zone
http://servername         http://servername         Default
http://aa.company.com     http://aa.company.com     Intranet

One more thing why its asking to add http://aa instead of http://aa.company.com
1

SharePoint likes to know all URLs it is using. In the AAM settings are 5 zone. Each zone lets you configure an URL your users can visit an the browser won't redirect. For each zone you can add internal AAM mappings. There mappings allow SharePoint (not IIS) to identify the requested public zone the internal zone is mapped to. The browser will than redirect the browser to the public zone URL. All AAM settings must be also specified in the IIS bindings. If you only have one web app and created the web app without host header settings you are good to go. Otherwise go to IIS and configure the IIS bindings for the SharePoint site. Microsoft has an KB article online that talks about the support requirements around AAM and when to extend that site:

http://support.microsoft.com/kb/2624320

For your case you need to add http://aa as an internal mapping for the web app and point it to the "Intranet" zone. This will result in users being redirected to http://aa.company.com

Your authentication issues maybe related to other problems but that could be handled in another post.

0

Strange one - have you modified the host file on the server? Try a "ping aa" on the server and see what it resolves.

  • When we will ping aa and do nslookup aa it will resolve to aa.company.com – Pankaj May 21 '13 at 11:43
  • Is there any other AAM setting is required – Pankaj May 21 '13 at 11:45
  • Did you add the AAM setting for the correct webapplication? Any loadbalancer involved? – Max Melcher May 21 '13 at 15:33
  • no load balancer and AAM setting is for correct application – Pankaj May 23 '13 at 4:10
  • Please some one help me to resolve this issue ... – Pankaj May 29 '13 at 5:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.